I think my IPs got blocked


#1

Please help. I think my IP addresses got blocked by the Twitter API.

Running
curl https://api.twitter.com
from a couple of my servers just hangs. But, it works fine from my laptop and also from another server I have. Also, things were fine earlier today. Also, what is weird is
curl http://api.twitter.com
returns right away and says “SSL is required”.

I’d rather not post my IP addresses public. Can someone private message me or something?


#2

I think I’m facing the same issue. Any insights? This started about 2 hours ago.


#3

Definitely in the same boat here.
I was using cURL in the Abraham Twitter OAuth PHP library.

I tried regenerating some codes, and added more debug info. The status pages all said it was good, but seems not.
I added SSL certs and that did nothing.

Every time I just get:
Fatal error: Curl failed with error #28: Operation timed out after 0 milliseconds with 0 out of 0 bytes received


#4

My servers are on Rackspace, on the Chicago Region. I’m talking with Rackspace Support and it seems that all ORD Rackspace servers in the Chicago Region have been blocked, because we are creating new servers in the same region, and it doesn’t work, but when we create servers in another region, it works.

Does anyone from Twitter know something about this?


#5

I’m also at Rackspace in Chicago, although, I thought it worked at first when I booted up another server in Chicago. But, then it stopped working once I got my app running on it. Maybe the app itself is blacklisted and takes the IP address with it?


#6

My shared hosting is from LiquidWeb, on servers based in Chicago.
Not Rackspace, but the same city. So it’s a city-wide IP block…


#7

Ok, I just booted up another server at Rackspace in Chicago and it is blocked. I’m going to bed. I hope its fixed in the morning.


#8

Mulka, could you ask to the guys on Rackspace, to call Twitter? They will have a faster response. I’ve already filled a ticket, both on Twitter and Rackspace.


#9

Just talked to a rackspace support person. They’re on it. As much as they can be anyways. I have a feeling this one is on Twitter’s end. In the meantime, I moved my app to Virginia.


#10

Suffering from exactly the same problem with some servers in Chicago :frowning:


#11

Hello everyone.

Thanks for the reports and apologies for the frustration this is causing. We’re looking into the issue.

Appreciate that folks may not want to share IP addresses in public but if anyone is able to share an IP in the Rackspace range that is known to be affected we can look into it more quickly.


#12

Andy, I’m not at Rackspace, but I can confirm that i’m seeing similar issues where ssl connections to api.twitter.com are dropped which causes the client to appear to hang and timeout before ssl handshake is complete. I’m connecting from 69.58.188.0/24

From my monitoring, this issue exactly 5hrs ago for me at 04:30 UTC.


#13

Hi Andy,

The problem still continues. It worked for an hour, but then it stopped working again. If you give me an email I’ll send you the IP’s of our servers. We’ve also filled a ticket on twitter with the list our IPs ( Case# 06660174: general question - AleRigatuso - ref:00DA0000000K0A8.500G000000W6plz:ref ).

Thanks,
Alejandro


#14

Thanks, that ticket info will be helpful.


#15

thanks for this information, we’re studying this now.


#16

Hi folks - we think this should be resolved for the time being, but investigation into the root cause is ongoing.


#17

Thanks. It’s working now.


#18

Sorry to “me too” but I can’t curl either http or https from one of our servers (95.131.64.172) I presume it is affected by something similar to this?

If it helps, this seems to have kicked off for us about 8pm BST last night judging by the pile of error messages I have.

Edit: I hasten to add that its not a rackspace server…


#19

Andy, I can confirm this was also fixed for us as of about 12:00 UTC (2 hrs ago).


#20

thanks - this could be related and I’ll add your IP to our investigation. As I mentioned, we have not finished root cause analysis yet so there may be some further instability while we work to understand what happened here - we really appreciate your patience.