I/O Exception: peer not authenticated?


#1

I cannot figure this at all. Out of the blue, on Thursday I started seeing “I/O Exception: peer not authenticated” trying to post (or do anything) from our site. There was a similar case #1444, but that fix (which involved CF certs on the web server) did not explain the fact that the requests were failing on production, staging (different host), as well as my local dev. For troubleshooting, I created a new test app on the same account, ran an oAuth test - same result. I even created a new app from another account pointing to a different URL, updated the consumer data in my code and got the same error! I literally have no clue how to proceed at this point. Any insight or additional troubleshooting suggestions would be more than welcome.

Charset [empty string]
ErrorDetail I/O Exception: peer not authenticated
Filecontent Connection Failure
Header [empty string]
Mimetype Unable to determine MIME type of file.
Responseheader struct [empty]
Statuscode Connection Failure. Status code unavailable.
Text YES


#2

I’m getting the same issue. I’m using the coldfumonkey library to pull a user timeline feed onto a page. I have one site hooked up with the same library which is working fine, but the new site I’ve created won’t authenticate. Identical error: peer not authenticated.