I have a problem with Twitter Cards: Whitelisted but doesn't work


#1

Hi,

We set large image card, but it preview like summary card without picture, and it doesn’t work at all.
Our site is http://eztalks.haoshitong.com/
Here is the preview:

Thank you.

Regards
Sophie


#2

Hello Sophie,

The reason for this would be because when using summary_large_image, the image you choose must be at least 280 pixels wide and at least 150 pixels high.

From looking at your tags, I can see the image you’re trying to use in twitter:image is only 53 pixels wide and 53 pixels high.

You will need to resize it. I’ve quickly made two versions that you can save and see if they work.

  1. 280x150 IS transparent
    ( http://dalehay.me/twitdev/sophiestu-1.png )

  2. 280x150 NOT transparent
    ( http://dalehay.me/twitdev/sophiestu-2.png )

Hopefully that helps with your problem, if not, just let me know. :slight_smile:


#3

Hello Dale,

I 've tried your version, it remained the same, and I also resize my own picture to 280*150, still the same. Please check our site now, the image still there. We used to triy summary card before and it worked well. Now we need to update to large image card, it just stays like summary card, and cannot display the picture. Would you please check more details? Thank you.


#4

Hello Sophie,

I see that you have sorted it out now? :slight_smile:

Just checked on the Card Validator and it seems to show that it’s working correctly.


#6

That’s because the domain where your image is hosted has a robots.txt file that blocks the cards crawler from fetching your image - http://roliblog.wpengine.com/robots.txt


#7

Aha I see OK thanks very much for your help!


#8

Hi Dale,

Yes, worked finally. Not sure whether it’s beacuse of some space in the content. Thank you. However, recently I used APP card, it works well with iphone, but I cannot enter googleplay page to install the app when using android phone.
Still the site is

www.eztalks.com.

Here is a screenshot: