I can't send a DM with any links in it


#1

Can someone please help? Every time I try to send a DM out with a link to my book, it says "Sorry cannot be done. I used to send one message to each new follower. This has been going on for a while.
Thank you.


#2

It started on October 15 or 16 due to spam attack.
You can read more here: http://www.vicconsult.com/tips/twitter-dm-links-malware.html

As it states on Twitter support page this is temporary issue and team working on this, but it is now 1 month. So I don’t think they really working on fixing this.


#3

Still the case, except “Big” domains (i.e. a handful of those owned by large US corporations). It’s dishonest to make a policy change and pretend it is a technical issue. Not the way to engender trust. It would be just sloppy programming if this were a technical issue, as it delivers an utterly meaningless error message.

If one were honest, a statement would be made, and a link to that would be delivered in the error message.


#4

This seems to still be an issue. Feels like rather an odd choice.


#5

This is still an issue for me, cannot send URLs via DM. This is very annoying.


#6

Thanks for reaching out this is a known issue that is being addressed. In the meantime, please contact our Platform Operations team by using the “I have an API policy question not covered by these points” option at https://support.twitter.com/forms/platform and provide the link that you are trying to send via DM and we will respond as soon as possible.


#7

Use a line break after the URL, this worked for me.


#8

Have tried to send a link in my DMs without luck. I tried the line break, but does not seem to be working. Does anybody have an alternative solution? Thanks!


#9

The issue seems to be resolved for most of the users.


#10