I am trying to limit the returns from stream using the track command but cannot get this to work?


#1

I am trying to use the stream command. I can get this to work but when I try and add track to limit the results I am getting an error? Below is the query:

curl --request 'POST' 'https://stream.twitter.com/1.1/statuses/sample.json' --data 'track=lions' --header 'Authorization: OAuth oauth_consumer_key="XYZ", oauth_nonce="XYZ", oauth_signature="XYZ", oauth_signature_method="HMAC-SHA1", oauth_timestamp="1371901018", oauth_token="XYZ", oauth_version="1.0"' --verbose

The error I am getting is:

< HTTP/1.1 406 Not Acceptable
< Content-Type: text/html
< Transfer-Encoding: chunked
<
Parameter track not allowed in role statusSpritzer

  • Connection #0 to host stream.twitter.com left intact
  • Closing connection #0
  • SSLv3, TLS alert, Client hello (1):