How to solved, 406: Returned by the search API when an invalid format is specified in the request


#1

hi all, this is an error code 406 when i want to stream twitter using kafka by java.
im is a newbie for this topic, i use reference code from tutorialspoint.com/apache_kafka/apache_kafka_real_time_application.htm

and i get that error, And I only get a 406 response. I’ve looked into the oAuth, thinking it might be the problem, but from what I can gather, the 406 error has nothing to do with credentials… I should be getting the responses w/o any problems…

Can anyone please help me out with information?
I can provide more code if it would help…

Thanks in advance!


#2

Hi Chaqaz,

Did u get any solution for the above mention problem.I am facing the same issue.


#3

Neither post in this thread describes which API endpoint you are hitting, or a code example. Can you provide more information please?


#4

Thanks for the reply andypiper, We were able to solve the problem yesterday. Thanks for the support. Actually we were giving the search query which is not available for the end user / public access. So the problem got solved.


#5