How to authorize my app in Twitter?


#1

Hi

Little introduction:

I’m using the prime Unity3d prime31 Social Plugin, and I’m running into the
following problem: I cant authorize my app in Twitter on android
devices.

I know that it looks like my issue, or Unity issue, or Prime31 issue, but all possible variants were checked and nothing found… Hope that twitter guru can give me any clues.

Little introduction end.

Full bug description, steps to reproduce, *.apk test file and all checked variants are described here:

http://support.prime31.com/15842/how-to-authorize-my-app-in-twitter

If you have no account on prime, please read this shortened copy/paste below:

------Me:--------

Hi @prime31!

I’m using the prime 31 Social Plugin, and I’m running into the following problem: I cant authorize my app in Twitter on android devices. Here are my steps to reproduce:

Install and launch this *.apk
Press "Twitter Scene" button
Press "Initialize" Twitter
Press "Login" button
Enter twitter login / password and press "Authorize" button

Expected result: loginSucceededEvent / loginFailedEvent should be fired;
Actual result: Neither loginSucceededEvent nor loginFailedEvent fired, authorization dialog is displayed;

Device model: Asus TF300T, android ver. 4.2.1.

If I press “Back” button then loginFailedEvent (cancel) event is fired, and after that I’m able to authorize normally

Thanks

------Prime31:--------

Are you testing with the demo scene’s CONSUMER_KEY/SECRET? If not, run the demo scene unmodified. Have you tested on other devices? Do they have the same results?

------Me:--------

Im testing with the demo scene’s CONSUMER_KEY/SECRET, I can reproduce this issue on the following devices: Asus tf300t, Nexus 7 and ZTE Z5S mini

------Prime31:--------

I can’t reproduce this. Using the provided apk I tested on a Nexus 7, Galaxy S3, s4, s5 and a couple Motorola devices.

You may want to try flipping the demo scene over to use your own key/secret.

------Me:--------

Already tried my own key/secret - no luck.

------Prime31:--------

Do you have a proxy setup on your internet connection? Have you tried on different WiFi/Cellular networks?

------Me:--------

Tested both on wifi and on cellular (no VPN, no proxies); bug reproducible;

My colleague from SF (USA) cant reproduce it. It seems that this bug is reproducible only from Belarus.

I’ll check it tomorrow with VPN configured to different countries

------Prime31:--------

That definitely would make a lot more sense. If indeed the issue is only happening for you in Belarus I would almost guarantee there is a bug on Twitters servers. If you open a bug report with them and just send them the URLs the plugin prints to the log they should be able to find and fix the issue.

------Me:--------

Hi again

Tested with VPN configured to USA (whatsmyipaddress.com determines my location as LA) - bug is reproducible. GPS is off, no sim card.

URLs the plugin prints to the log are the same as yours both with VPN and without it.

Also I asked colleague from Russia to check this issue, she can reproduce it on Nexus 7 both with VPN and without it.

Also tested logging in with native twitter app from google store and via browser - works ok with/without vpn.

------Prime31:--------

That is indeed very odd. I will see if I can procure a VPN outside of the USA or UK (both of which definitely don’t show the error) to try to narrow down what is happening.

------Me:--------

Please try my twitter account. May be it is the reason of this behaviour.

------Prime31:--------

I just logged in and posted with those credentials without issue.

------Me:--------

I have no idea what can cause this issue :frowning:

I uploaded video of bug reproducing, just to prove that it realy exists: www.dropbox.com/s/e5ya77e4aowml5d/VID_20141002_182345.mp4?dl=0

------Prime31:--------

That definitely looks like an issue on Twitter’s servers. They dont ever succeed with the login and just show the authorize page after logging in.


#2

how to use my application to login to twitter, i want autenticate/authorization link for my twitter application how to find or create it…

example a link
https://api.twitter.com/oauth/authenticate?oauth_token=oUUtmSiYQmXKxCeVHCsPnEzDr0GURsUh1ZAnGpZ