How the heck do you get these cards to work?


#1

Hi

I’d really love to use Twitter Cards on my blog frankbukowski.com

My problem is I’m not a web developer or coder, I’m a simple writer.

I hoped Twitter Cards would be easy to install and use. They look awesome.

But there seems to be lots of fragmentary, incomplete, conflicting information about Twitter cards online (including these discussion boards), that is mostly aimed at coders/developers, which reads like Chinese to me.

Some information suggests I need to paste code into my blog, other information says if I am using SEO Yoast or All in One SEO on my blog, that should pull the meta information automatically into my post pages, so the twitter cards should work automatically.

I use All in One SEO on my Wordpress blog frankbukowski.com I have activated the Social Meta feature of All in One SEO.

I installed and activated JM Twitter Cards on my blog.

I went through the validation/application process for the Twitter Card, pasting in the URL of a post I wanted to tweet, using a summary card, and got an email back from Twitter saying:

Your Twitter Card is ready!
We’ve activated the summary card for frankbukowski.com.
If you want to use other kinds of Twitter cards (and we know you do), please make another request.
Get another card

But it didn’t tell me how to get the Twitter card to work.

When I tried tweeting the URL for the blog post that had apparently been activated, no twitter card showed up in my tweets. Just a normal tweet with the URL link to the blog post. No card.

Here’s a typical blog post of mine. http://www.frankbukowski.com/52-pick-up-by-elmore-leonard-book-review/

When I look at the admin page for this post in my Wordpress dashboard, there’s a ‘Twitter Cards’ panel in there, with three buttons - Documentation, Validator, Troubleshooting.

Underneath the three buttons is a box including the following code:

<!-- JM Twitter Cards by Julien Maury 5.2.2 -->
<meta name="twitter:card" content="summary">
<meta name="twitter:creator" content="@FrankBukowski1">
<meta name="twitter:site" content="@FrankBukowski1">
<meta name="twitter:title" content="52 Pick-up by Elmore Leonard - book review">
<meta name="twitter:description" content="Book review of 52 Pick-up by Elmore Leonard -  a Flawed but highly readable early crime thriller by the daddy of naturalistic dialogue">
<meta name="twitter:image:src" content="http://www.frankbukowski.com/wp-content/uploads/52-Pick-up-featured-image.jpg">
<!-- /JM Twitter Cards -->

When I click on the Validator button, it takes me to the Card Catalog at Twitter.

I click on the Summary Card to choose it.

I click on the Validate & Apply tab

In the box where it says ‘Enter URL to validate’, I paste in the URL to my blog post: http://www.frankbukowski.com/52-pick-up-by-elmore-leonard-book-review/

I click the ‘Go’ button.

The Card Preview shows me how the Summary Card will look, it looks fine.

At the top of the LH column there’s a message saying *.frankbukowski.com approved

At that point, like most non-developers, I start scratching my head. There’s no instructions as to what to do next.

Okay, so I assume (guess?) I need to I head over to Twitter, and open up a Tweet and past the blog post URL in: http://www.frankbukowski.com/52-pick-up-by-elmore-leonard-book-review/

I tweet it, but only the URL link appears in the tweet. No twitter card.

I know I’m a dumb no-coder but can someone tell me if I’m doing something REALLY OBVIOUSLY WRONG, that will be easy for me to fix?

Or are Twitter cards really only supposed to be used by web developers? Is it a dark art that is going to be beyond normal human beings without developer knowledge?

I’m hoping someone can help, but it feels a bit like the wild west, trying to find someone who can explain this to a non-expert in simple English, without saying something like, “set the robots.txt to accept twitter’s bot”, which means absolutely nothing to me.

If I really need to have that level of geeky knowledge to have a hope in hell of ever getting Twitter Cards to work, can someone please put me out my misery and just come out and say so, then I will give up trying.

Sorry for the long message.

Hope someone can shed some light on this for me.

I’d really love to use Twitter Cards, if I could get them to work. They look awesome when I see them on other people’s twitter feeds.

Cheers

Frank


#2

For some reason the code didn’t appear in the message, even though I pasted it in. I’ll try again here:


#3

Can’t get code to appear, don’t know why. Every time I paste it in here, nothing appears, except this message. Sigh.


#4

Hi Frank

I’m really sorry you’re having issues. I’ve fixed your original post to include the code (I added code tags around what you had pasted in).

What I would suggest is reading through the JM Twitter Cards Troubleshooting FAQ http://wordpress.org/plugins/jm-twitter-cards/faq/ … one thing you could try is making sure that your site’s robots.txt file allows Twitterbot (our spider) to access the site.

Having said that, this may also have been a caching issue on our side. I’ve just tried tweeting your link -> https://twitter.com/evilpiper/status/466551090901561344 and I’m seeing a card for that blog post now.


#5

Hi Andy
Thanks for replying. I had read the JM Twitter Cards troubleshooting FAQ but I still couldn’t seem to make any headway. Where would I find my robots.txt file and how would I know it allows Twitterbot to access the site? I’m just running a simple wordpress blog so I don’t really mess around with code much, sorry. I have a feeling it may well be something to do with the file you indicate though, just not sure where to find it or check it.
Frank


#6

So either your web host is providing robots.txt for you; there’s a Wordpress plugin you have managing it; or, you should just find it in the root / base location for your blog (next to index.php and other such files)

However - as I said, when I tweeted a link from my test account earlier (link above), the card shows up. Is that not happening for you still?


#7

Nah, it’s still not happening for me Andy, just tried it again.

I’m not pasting code in anywhere. All I’m doing is putting the blog post URL through the card validator, and when that tells me my site has been accepted, I then paste the same blog post URL in a tweet, but I just get the URL appear, no twitter card.

Should I be pasting something else somewhere. I notice when I put the post URL through the card validator, it brings up a bunch of ‘Sample Embed Code’ on the bottom RH side. That’s different to the JM Twitter Cards code I mentioned when I first opened this discussion. Am I supposed to be pasting the ‘Sample Embed Code’ somewhere?

By the way, I tried it in Internet Explorer and it seemed to make no difference. I mainly use Chrome and it and/or Adblock sometimes do funny things. But I.E. didn’t work either, still no twitter card appearing.

And no, I don’t have a wordpress plugin managing my robots.txt. Had a look in the location where the other php files seem to be, but can’t see anything relating to robots. Should I ask my web host about it?

Appreciate your kind help on this, by the way.

Cheers

Frank


#8

Hi Andy

I checked with my web host TSO and they said they don’t block robots.txt

They also mentioned that Wordpress would have automatically added a virtual robots.txt file to my site, but there wouldn’t be a hard copy on the server to edit. They did however also provide a link to this rather cool site that lets you check the robots.txt file for your site:

http://www.frobee.com/robots-txt-check

The rules for mine came back as follows:

1 User-agent: *
2 Disallow: /wp-admin/
3 Disallow: /wp-includes/

Which from what I can gather means all bots are able to search my site fine, except for the ‘WP admin’ area, which is good! and the ‘wp-includes’ area, whatever that is. But from the above, it wouldn’t seem to be a robots.txt rule that is preventing Twitterbot pulling the info it needs for my Twitter Cards. Is that right?

So I’m still left scratching my head as to why I can’t get them to work.

Frank


#9

You’re right, robots.txt should not have been the issue, I was just checking all the options.

What are you using to view the tweets containing the URLs?

I’ve just picked another post at random, and tweeted it from my test account.

The card does show up on web:
https://twitter.com/evilpiper/status/467314595204313088
https://dl.dropboxusercontent.com/u/1312244/Twitter___evilpiper__how_about_http___t_co_z3kKBTVHES.png

Note that it doesn’t show up in the main timeline view unless I click the small Summary icon under the tweet; it does not show up on mobile. This is the expected behaviour for cards.


#10

the JM Cards plugin is generating its own version of the embed code for you, so no you don’t need to do anything with our sample embed code.


#11

I’m just viewing the tweets online, via Chrome or Internet Explorer. Neither shows up the twitter card, just the blog post url in my timeline. There’s no ‘summary’ icon underneath to expand, that was the first thing I looked for. I’ve tried just about everything now.

Can you tell me exactly, blow by blow, what it is you do, to get them to work on your test account? Maybe I’m just doing something really obvious wrong. I don’t think so, but I’m no expert so it’s possible.

Thanks


#12

Anyone else out there got any ideas? Much obliged.


#13

Frank, you can see the summary cards from your site links visible here, in a short screencast I recorded: https://www.youtube.com/watch?v=RWxJ4LngTB4

Are you not able to see anything in the tweets that I linked to above?


#14

A card also shows up with this tweet for me in Chrome https://twitter.com/FrankBukowski1/status/467067772238053376


#15

Hey Andy, it started working!

Don’t know what happened. Every other time I’d tried, there had been no ‘view summary’ link, to open the card. I had been able to see the ones you sent me though.

But I just went in and tweeted two blog posts as Twitter Cards, and they both worked. Awesome. Not sure why it suddenly started working. I think there may have been an update of the JM Twitter Card plugin in the last couple of days, maybe that fixed it.

Can’t thank you enough for all the help you’ve been mate.

I’ll give you a follow on Twitter, if that’s okay.

Cheers

Frank


#16