How do you get Twitter Widget ID?


#1

I want to know how to get a twitter widget id
Thank you!


#2

By creating widgets using the configurator at https://twitter.com/settings/widgets


#4

Gracias! Magnifico


#6

settings => widgets => create new

set your setting then create widget .


#7

I want to know how to get a twitter widget id
Thank you!


#8

In your twitter account go to
settings => widgets => create new

set your setting then create widget .


#11

Espero el id widget


#12

Could someone explain what the id of the widget is? ie; is it tweets by wishywashyco ? or is it contained in the code?
thank you


#13

A widget ID stores the configuration of a widget you configure on Twitter.com in a unique identifier.
https://twitter.com/settings/widgets/new/user

Once the widget is on the page you may change the widget configuration on Twitter.com and see changes reflected on your site, such as changing the link color from blue to red.


#14

Widget ID is NOT being created or added when I create a widget for inclusion in a web page. As a result, all we get on the page is a link to the twitter account, not a feed/timeline.


#15

@GetOnlineSpain - exactly the same problem


#16

Us too: in fact, widgets that have been created over the last 2 years are now MISSING the data-widget-id when viewed on the Edit Widget screen.

Workround: manually add the id - it’s the long number in the URL of the widget when you’re editing it. (Thanks, #rmcbryer, for the workround)


#17

Had same question. Widget builder won’t display the widget ID in the page, won’t inject it inside the auto-generated source code. (BUG!)

But, after you created the widget, check your browser’s address bar, the widget id is inside of the URL.

Copy the source and paste to your HTML, then copy the id and inject it into the source.


#18

Open you widget, then check the browser address bar for that long number, which is the ID.


#19

same problem here. help needed


#20

worked for me!! thank u so much. wasted so much time on this and finally got it!


#21

Thank you so much!!! I had the same problem and this fixed it!
Was only showing:
data-widget-id=""


#22