How do I test @anywhere tweetbox locally


#1

Hello all,
I am trying to test the tweet box in my development environment, but I keep receiving the same error:
Something is technically wrong.
Thanks for noticing—we’re going to fix it up and have things back to normal soon.

I have set my API_KEY and read/write access correct, so I am wondering if this is happen because of the callback url of because of some other thing I haven’t noticed. Do I have to set the “localhost” as my callback URL? Is a callback URL always needed when working with the tweetbox?

Thanks for the help


#2

Hi @QualCanal,
I too faced the same problem and I fixed it by setting the callback URL as same as Website URL… Now it works perfectly… on my local machine


#3

If you’re running on localhost, you may need to trick your DNS (usually by editing /etc/hosts in UNIX environments) to temporarily consider one of your registered domains as pointing to your local machine.

For example, if I set my callback URL to: “http://mytestanywhereapp.com/

And then edited my /etc/hosts file such that my machine (127.0.0.1) was considered mytestanywhereapp.com:
127.0.0.1 mytestanywhereapp.com

Then I could use the web browser to navigate to mytestanywhereapp.com and have it load from my own machine and @Anywhere’s security requirements would be satisfied as I developed.


#4

thank you very much!


#5

#6

#7