How do I get Twitter OAuth to work with the Sorcery gem in Rails 4?


#1

I am currently having trouble getting OAuth to work in Rails 4 using the Sorcery gem. I have followed this tutorial on the Sorcery wiki to set everything up: https://github.com/NoamB/sorcery/wiki/External and right now I am getting to the “Sign in” page during the authentication process with Twitter BUT when I click on the “Sign in” button, the callback URL isn’t triggered properly. I have supplied the exact callback url that was given by Sorcery in this line of code in the sorcery.rb file:

config.twitter.callback_url = “http://0.0.0.0:3000/oauth/callback?provider=twitter

I’ve tried various things to get this to work, I’ve tinkered around with the “Permissions” in the Twitter developer console and I’ve try different configuration options but nothing has worked.

If anyone could provide any advice, suggestions or feedback, or if anyone has had experience doing this then that’d be greatly appreciated.

Please ask if you need more information to understand what I’m trying to do here.

Also does anyone think that Twitter might have changed something in their API that may make it incompatible with the current version of the Sorcery gem?

Thank you!