How do I get the twitter timeline to embed to work in wordpress?

wordpress

#1

So a couple years ago I tried to get the timeline widget in my wordpress site. The widget in wordpress didn’t work. Just a text link. I looked around and tried to embed it with the text widget. Also didn’t work. I looked around for a solution. I found dozens. After hours of trying to get it to work I gave up.

I recently changed my site layout and I ended up trying again. Same thing. Widget doesn’t work. Everything I embed is just text. It just says //platform.twitter.com/widgets.js. I’m now hours deep into the same futile search for answers. It appears the same question has been asked dozens and dozens of times and has received dozens and dozens of answers. None of the answers I’ve tried seem to work. I’m at the end of my rope here.

I got to publish.twitter.com and get

<a class="twitter-timeline" data-width="260" data-height="400" data-theme="dark" href="https://twitter.com/ZackGo55">Tweets by ZackGo55</a> <script async src="//platform.twitter.com/widgets.js" charset="utf-8"></script>

It will not work in my site. Just a text link. I’ve wasted hours tinkering with this thing. Apologies if it’s been answered somewhere else but like I said, I’ve probably spent days of my life looking for the answer that actually works for this and I still don’t have it. Please help. Thank you.


#2

A link with no rendered timeline on your site is most likely the result of Twitter’s widgets JavaScript stripped from your page. Your WordPress configuration may strip the <script> component of your copy-and-pasted HTML.


#3

The most likely cause is what @niall is describing. You may be losing the script tag, or have something conflicting in your Wordpress Javascript plugins.

One other thing you could try, is just adding in https: on the front of the piece where the cut-and-paste embed code refers to //platform.twitter.com/widgets.js. I’ve seen that trip up a couple of browsers in testing from time to time.


#5

This isi happening in Rapid Weaver tool, as well, not just WordPress. I’ve found many others with same problem over the years with many posts and honestly, no real solid solutions from Twitter. I have no problems embedding LinkedIn and Facebook, only Twitter seems to have this unique mess when it comes to their widgets.


#6

I’m flagging your post as inappropriate. I’m sorry you are frustrated with our new publishing solution but I would encourage you to read the community guidelines and moderate your language and terms of expression. Thank you.


#7

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.