Help: Twitter Widget not Working


#1

EDIT: Apparently people are still reading this thread, so I’ll try to summarize it. We resolved this problem for ourselves by adding the domain to a whitelisting field. However, it seems like they’ve removed this feature from the widget settings, the widget no longer asks for domains.

If you’re still having problem, you may want to try adding a “http://” or “https://” to where it refers to the javascript (e.g “//platform.twitter.com/widgets.js” -> “https://platform.twitter.com/widgets.js”).

Best of Luck!

ORIGINAL:

Howdy,

I cant get the Twitter Widget to display on my site. I tried putting it as part of the content, making an .html file with the code on the website and the same locally. cant get it to work. All it displays is a link with “Tweets by @LaggyGamerz

Here is the code:

Tweets by @LaggyGamerz

#2

Nvm, fixed issue. Problem was with domain (www.domain.com vs domain.com)


#3

I tried entering my domain both ways, and still have only the “Tweets by” heading showing up - no feed at all.


#4

im having the same issue embbeding the widget in my page www.rebelandrewp.com instead of a widget its just a link that appears tweets about ‘‘rebel andrew p’’ i like to use this widget feature, help would be appreciated thanks


#5

I am having the same problem that the widget does not show at all placed as a html widget on my site cozmicsoulfire.com first showed that favorite tweets@cozmicsoulfire link now not even that :frowning:


#6

Similar issue here. I created the twitter widget with two domains, one is our main site, the other is facebook (for our facebook page). Widget shows up fine on our site, but doesn’t show up on the facebook page tab (all I see is “Tweets by @UTheos”).
On our site (right column, scroll down): http://www.universaltheosophy.com/
On our facebook page: http://www.facebook.com/TheosophicalPath/app_208195102528120

Same widget.


#7

Check your javascript console for error messages.


#8

I’m having the same problem. The widget is displayed when I access my site from a PC using Google chrome. However, when I access my site from any Mac, my iphone, or my google nexus 7 the space where the widget is supposed to show up only displays the text “Tweets by @Mytwittername

Here is an example of what it looks like, notice the blank space on the right side: http://s11.postimage.org/6d6fn9itt/twitterwidget.png


#9

Like every one else, all I get with the timeline widget (IE & Chrome) is “Tweets by @TenancyServices”. http://www.tenancyservices.co.uk/pages/twitter

I have both www.tenancyservices.co.uk & tenancyservices.co.uk in the whitelist. When I add tenancyservices.myshopify.com (it’s original address) to the whitelist, it reports an error “unable to update your widgets, please check your inputs”.

The widget doesn’t only not work on my site, even the preview on the widget configurator fails to show.


#10

The old widgets worked great and now the news ones don’t work at all. I’ve tried every suggestion here. Very annoying.


#11

Has anyone found a fix? My developers are pulling their hair out. The failure to load tweets to our website halted abruptly.


#12

I’ve got the same problem. Noticed that widgets.js doesn’t load.


#13

Having the same problem on my site but actually hate this new feature as I only want to show the most recent tweet on my website, not recreate twitter on my own site. Will probably have to take the twitter feed off completely - shame as it used to work perfectly!!


#14

Has anybody found a solution? It still not working…


#15

i had the same problem.
the error was caused by the extension “antisocial”


#16

Had the same problem and it worked for me!

What you have to do is to add one EXTRA domain name on the “widget configurator” section (settings->widget->“your selected widget”->domains), e.g. if you had “domain.com”, type in “www.domain.com” (separate with comma).

Thank you @LaggyGamerz for the tip.


#17

Have been trying all day to add the Twitter Gadget to my Blog in blogger but it is coming up with an Error message? Is is faulty or have I done something wrong? I then tried to add a twitter button direct from twitter by pasting the code into the HTML in blogger but it came up as another error? Have anyone else had this problem today? My twitter button?link from Blogger was working fine yesterday?


#18

worked for us - thanks!


#19

Omg what is going on with this. They really need to change this back. Why does the code end with a script language? (See below)
I don’t feel like this code is just html. It says “js” in it which is javascript

Tweets by @yazdesignz

#20

I got it work! Been driving me nuts for hours!
Source path is broken…
In the line of code, add http: just before // in the source path.

Tweets by @fjmdesigns