Having issues with tweet button count on new websites


#1

My company does a lot of microsites for sweepstakes. These sites always include a tweet button. We’ve been having problems with the tweet buttons not updating the count. some of our sites have been around months and the count is stuck at a certain number, others, they go up and within a few weeks they’re done. In that time the tweet count stays at 0, but if I search for the tweeted url (full url, not short) I get plenty of results.

A few months ago, I was asked to look into the issue and discovered that the data-counturl on some sites was set to the same short url used for data-url. After reading documentation I changed that so the counturl was set to the full resolved url (including query string) and it worked. However, that was back in June, and the last 3 microsites we’ve done since August using the same method are not working.

Here’s the code:

<a href="http://twitter.com/share" class="twitter-share-button" data-url="http://urb.an/6FpmE" data-counturl="http://getinpsired.urbandaddy.com?utm_campaign=ClubMonaco&utm_source=UD&utm_medium=Twitter&utm_content=Post" data-text="Get inspired. You. 3 friends. Win VIP tix from @MercuryRecords, rooms @HudsonNYC & $5000 @ClubMonaco:" data-count="horizontal" data-via="urbandaddy" data-related="@urbandaddy">Tweet</a><script type="text/javascript" src="http://platform.twitter.com/widgets.js"></script>

here’s the latest page using that code. http://getinspired.urbandaddy.com/signup/thanks

thanks for your help.


#2

In this very particular case, it looks like you’ve made a typo in your data-counturl value (look at the subdomain, it’s “getinsired” instead of “getinspired”)


#3

DOH! yes, that is a typo. that was the result of the product managers giving me the urls, then changing the short url with the corrected domain, but the long url did not get corrected. Dumb of me not to catch that.

Looks like it’s working now on dev environment, Sorry for the fire drill. If you have the ability to delete the thread, feel free.

  • keith

#4

@episod Could I jump in here for a second? I’m using a social media plugin called WP Social Lock to promote our white papers. The twitter count has been stuck at zero even though I know there are tweets. I’ve been googling solutions and I’ve tried a few things to get it to work with no success and I’m frustrated now. I’m hoping the experts on this forum will have some answers. The page where the plugin is active is http://www.ballantine.com/direct-marketing-white-paper/. I appreciate any and all help I can get, thank you.


#5

Is anyone out there that can help? I really need to resolve this issue with the Twitter button asap and I’m completely stumped. Thank you!


#6

I see a count of 61 on that page - what exactly is the issue you’re having with the count?


#7

I have the same situation but I am working in a local computer, I dont know if this would have any effect. I am using a framework so the url is identical (plus, I tested it from one of the tweets and its correct), the count just doesnt go up, could it be cached by twitter perhaps?
Edit: I wanted to add that going to http://urls.api.twitter.com/1/urls/count.json?url=http://localhost/full-link/ shows the counter at zero, even after several tweets of that same url. I made sure to use data-count and data-counturl


#8

Hi Arne, I went ahead and started playing around with the plugin code…and I’m far from a developer, but it appears I got it working. I will monitor the count to make sure it keeps going up. Thanks for the response.


#9

Localhost will never increment - there’s no way for Twitter’s servers to address content using that hostname.


#10