Have metatag and robots.txt - so why does fetching fail?


#1

Hi,
I have this link : http://mediamatters.org/video/2014/09/02/either-convert-them-or-kill-them-hannity-turns/200613

which give me an error : Fetching the page failed due to an internal error, debugId: 1409754319-357323

any post on the site has twitter summary card set up…
When i try it on the try cards tab of the validator it works but when i enter the url in the validate and apply tab its giving me the error…
Is it because we are not in your active whitelist?
Any help appreciated
Thanks


#3

Thank for a more friendly user interface.
Now i can see the why of the error i am having on card validator.
Here’s what i get :

INFO: Page fetched successfully
WARN: No metatags found

but i have the metadata:

link for verification of metatag.
So why is it not seeing it?


#4

Thanks for the note, that’s indeed surprising.

I notice you have two twitter:image tags but I don’t think that’s the problem. Could you possibly try commenting out the Open Graph tags just to see if they could be the cause of a conflict? We normally integrate seamlessly with them and inherit from many values, but just in case.

Regarding your question about the whitelist, the validator enables you to get your entire domain name enabled for Cards when submitting a sample URL, so it’s meant to work for any valid URL.

Please keep us posted.


#5

Thanks for your answer.
It is going to be difficult to do as people are actively posting article to the website and facebook.
Any other way of troubleshooting this problem?
Is there a way to test it locally (localhost)?
How’s the caching going to affect the page? will i have to wait a few hours?


#6

Thanks, I understand. Any chance you could isolate just the tags on an independent page on your domain to perform tests? Could you also keep only one twitter:image tag?

Please check out our troubleshooting guide for Cards for more tips such as how to debug Cards and avoid the cache.

Cheers,
Romain


#7

Hi there,
same here. I’ve been struggling to get a valid card on this url: http://photo.wistiti.me/8VVF1
Meta tags are in the code, twitter bots should be welcomed.
And I get “WARN: No metatags found” on the card validator.
Any pointers?
Thanks for your help.


#8

I can’t quite understand why this is failing either, but as @romainhuet said to the previous poster, perhaps you could try temporarily commenting out the Open Graph (og:) tags and validating without them, to see whether the validator is getting confused between the two sets of meta tags in your page.


#9

Thanks for your answer @andypiper.
I removed all the Open Graph tags, and my page is still not valid.
I made a specific static page: http://photo.wistiti.me/testtwittercard to run some tests.
Any other idea?


#10

Ok, I simplified the code at this url: http://photo.wistiti.me/testtwittercard
It only contains the Twitter metas tags and one image tag in the body.
The bots should be allowed here http://photo.wistiti.me/robots.txt and there http://p.wistiti.me/robots.txt

Why can’t the card be validated? What am I missing?


#11

Hi everyone,

I am also having this issue. On attempting to validate my website for Twitter cards using the card validator I am getting the message ‘Unable to render card preview’ with the following error log:

INFO:  Page fetched successfully
WARN:  No metatags found

I have set up my meta tags as follows in this example:

<!-- Twitter -->
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:site" content="@TheTwitterSite">
<meta name="twitter:creator" content="@TheTwitterUser">
<meta name="twitter:image:src" content="http://cnd.domain.tld/images/cardimage.jpg">
<meta name="twitter:title" content="The Sites Title">
<meta name="twitter:url" content="http://domain.tld/">
<meta name="twitter:description" content="A useful example description">

I would assume that the above would meet the minimum requirements to load the card data. I also have other OG tags here for sharing on Facebook.

On running a curl -A “Twitterbot/1.0” http://domain.tld I can see the meta tags are included in the generated html.

An important thing to note is that I am using the Meteor Javascript framework, and using a package for server side rendering to generate SEO friendly html for bots and scrapers.

Could this be having an impact on what I am trying to do, despite the fact that running curl returns what appears to me to be the correct generated html?

Is there a way we can see what html was fetched by Twitter, along the lines of what you can do with Google Webmaster tools and Facebook?

Thanks,

Matt


#12

@bentalou, it’s working for me in the validator now. Can you see if it’s working for you too? If not, then can you give me your ip so that we can see if it’s a geo/data center issue.
@matfinucane, the dns resolution failed for http://domain.tld, can you check that please?


#13

Hi,

That was a dummy domain, the real one being as follows when I run the curl command:

curl -A “Twitterbot/1.0” http://annachristoffer.com/de

The response comes back with all the html that I need, including these tags for Twitter

<!-- Twitter -->
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:site" content="@AnnaChristoffer">
<meta name="twitter:creator" content="@AnnaChristoffer">
<meta name="twitter:image:src" content="http://media.annachristoffer.com/images/projects/thumbnails/carnival@2x.jpg">
<meta name="twitter:title" content="Anna Claire Christoffer">
<meta name="twitter:url" content="http://annachristoffer.com/de/">
<meta name="twitter:description" content="Konzeptionelle Gestaltung von Anna Claire Christoffer">

When attempting to run this in the validator it still tells me there were no metatags found. Below is the remaining contents of the head file incase anyone spots anything that might cause the validator to fail.

<!-- Open Graph -->
<meta property="og:url" content="http://annachristoffer.com/de/">
<meta property="og:site_name" content="Anna Claire Christoffer">
<meta property="og:type" content="website">
<meta property="og:title" content="Anna Claire Christoffer">
<meta property="og:description" content="Konzeptionelle Gestaltung von Anna Claire Christoffer">
<meta property="og:image" content="http://media.annachristoffer.com/images/projects/thumbnails/carnival@2x.jpg">

<!-- General -->
<meta name="description" content="Konzeptionelle Gestaltung von Anna Claire Christoffer">
<meta name="author" content="Anna Christoffer">
<link rel="canonical" content="http://annachristoffer.com/de/">

Any ideas what might be happening?

Thanks,

Matt


No metatags found, but I can see them
#14

Hello everyone, I have the same problem. Please help me. thank you


#15

Hi guys.

I had the same issue yesterday. The reason was my server side script was not sending Content-Type: text/html header. You may want to check your code to see if this is the same case.

Cheers!


Twitter Cards Validator issue - have tried all official troubleshooting suggestions
No metatags found when matatags exist
#16

This is it !!! been struggling all night. no content type => no card !!


#17

FWIW I also had to remove the ‘x-content-type-options’ header that was added by some previous Express middleware.


Cards Validator cannot find metatags with Shopify’s HTTP headers
#18

I was getting the same error on the card validator, despite having Content-Type: text/html set—

INFO:  Page fetched successfully
WARN:  No metatags found

In my case, the problem was solved by replacing Unicode apostrophes in the meta tags () with regular straight ASCII apostrophes (').

Cheers


#19