Gradle sync error while fetching moat-mobile-app-kit

mopub

#1

I am trying to update mopub SDK to 5.1.0. Whenever we do gradle sync, we get these 2 errors:

I can’t access those URLs from a browser as well, tried to access those URLs from a server machine with a different IP address, the same result. I get “access denied” in all scenarios.

Some help would be greatly appreciated.


#2

Hi,

This is a known issue that causes Moat 2.4.1 build errors that affects publishers using MoPub Android SDK 4.20.0+, One by AOL 6.8.1., Android Studio 3.1.2 and the latest Gradle build tools.

There are two workarounds:

  • Option 1: Disable Moat on the MoPub’s side. This will disable viewability via Moat.
  • Option 2: Publishers integrating the MoPub SDK binary cloned from GitHub can manually upgrade the Moat SDK version from 2.4.1 to the latest (2.4.5 as of this writing).

Note, a fix has been included in the new SDK version 5.2. we just released:

We encourage you to update your version when possible.

Thanks,


#3

I’m trying to integrate Mopub into the fire app builder by amazon and running into this issue. I’m currently running the latest Moat sdk (2.4.5) and I have the latest SDK (5.3). How do I disable Moat?


#4

Hi!

To disable MOAT. Exclude docs here:
https://developers.mopub.com/docs/android/viewability/#step-1-integrate


#5

I get this error even on 5.4.0 or 5.2.0. Using Android Studio 3.2.1, and followed instructions on https://developers.mopub.com/docs/android/getting-started/ using the standard JCenter (AAR) approach.
I get the same errors in the Android console @ : -

Metadata of https://s3.amazonaws.com/moat-sdk-builds/com/moat/analytics/mobile/mpub/moat-mobile-app-kit/2.4.5/moat-mobile-app-kit-2.4.5-sources.jar


#6

Yes same here. It’s never been fixed.


#7

I am seeing 403s all the time from s3.amazonaws.com/moat-sdk-builds/ as well


#8

Hello!

I just reproduced the issue and have a fix!

Step 1) In gradle-wrapper.properties, ensure you are using distributionUrl=https://services.gradle.org/distributions/gradle-4.10.2-all.zip

Step 2) Ensure that in your application’s gradle script, you have
maven { url “https://s3.amazonaws.com/moat-sdk-builds” } in both the buildscript and allprojects sections.

Let us know if that fixes it for you.


#10

Doesn’t fix it for me.