Getting NULLs instead of numbers


#1

Hello everyone,

We are seeing the same error on all accounts running (Ad account ID’s 18ce54fa9ux, 18ce54f4e4n, 18ce54f4hse) - getting NULL instead of real campaign metric numbers.

Is this a global bug on advertiser API or specific account-based issue?

Thanks in advance for your replies.


#2

@HttpoolRu_Ads: In order to help, we’ll need some additional information. Please provide an example request and response.

For additional details, see Guidelines for Reporting Issues.


#3

Hi! Please check example below

{“data_type”:“stats”,“time_series_length”:4,“data”:[{“id”:“8vn7r”,“id_data”:[{“segment”:null,“metrics”:{“impressions”:null,“tweets_send”:null,“billed_charge_local_micro”:null,“qualified_impressions”:null,“follows”:null,“app_clicks”:null,“retweets”:null,“likes”:null,“engagements”:null,“clicks”:null,“card_engagements”:null,“poll_card_vote”:null,“replies”:null,“url_clicks”:null,“billed_engagements”:null,“carousel_swipes”:null}}]},{“id”:“8vnbl”,“id_data”:[{“segment”:null,“metrics”:{“impressions”:null,“tweets_send”:null,“billed_charge_local_micro”:null,“qualified_impressions”:null,“follows”:null,“app_clicks”:null,“retweets”:null,“likes”:null,“engagements”:null,“clicks”:null,“card_engagements”:null,“poll_card_vote”:null,“replies”:null,“url_clicks”:null,“billed_engagements”:null,“carousel_swipes”:null}}]},{“id”:“8voev”,“id_data”:[{“segment”:null,“metrics”:{“impressions”:null,“tweets_send”:null,“billed_charge_local_micro”:null,“qualified_impressions”:null,“follows”:null,“app_clicks”:null,“retweets”:null,“likes”:null,“engagements”:null,“clicks”:null,“card_engagements”:null,“poll_card_vote”:null,“replies”:null,“url_clicks”:null,“billed_engagements”:null,“carousel_swipes”:null}}]},{“id”:“8voqr”,“id_data”:[{“segment”:null,“metrics”:{“impressions”:null,“tweets_send”:null,“billed_charge_local_micro”:null,“qualified_impressions”:null,“follows”:null,“app_clicks”:null,“retweets”:null,“likes”:null,“engagements”:null,“clicks”:null,“card_engagements”:null,“poll_card_vote”:null,“replies”:null,“url_clicks”:null,“billed_engagements”:null,“carousel_swipes”:null}}]},{“id”:“8voge”,“id_data”:[{“segment”:null,“metrics”:{“impressions”:null,“tweets_send”:null,“billed_charge_local_micro”:null,“qualified_impressions”:null,“follows”:null,“app_clicks”:null,“retweets”:null,“likes”:null,“engagements”:null,“clicks”:null,“card_engagements”:null,“poll_card_vote”:null,“replies”:null,“url_clicks”:null,“billed_engagements”:null,“carousel_swipes”:null}}]},{“id”:“8vq8g”,“id_data”:[{“segment”:null,“metrics”:{“impressions”:null,“tweets_send”:null,“billed_charge_local_micro”:null,“qualified_impressions”:null,“follows”:null,“app_clicks”:null,“retweets”:null,“likes”:null,“engagements”:null,“clicks”:null,“card_engagements”:null,“poll_card_vote”:null,“replies”:null,“url_clicks”:null,“billed_engagements”:null,“carousel_swipes”:null}}]},{“id”:“8vohq”,“id_data”:[{“segment”:null,“metrics”:{“impressions”:null,“tweets_send”:null,“billed_charge_local_micro”:null,“qualified_impressions”:null,“follows”:null,“app_clicks”:null,“retweets”:null,“likes”:null,“engagements”:null,“clicks”:null,“card_engagements”:null,“poll_card_vote”:null,“replies”:null,“url_clicks”:null,“billed_engagements”:null,“carousel_swipes”:null}}]},{“id”:“8wczv”,“id_data”:[{“segment”:null,“metrics”:{“impressions”:null,“tweets_send”:null,“billed_charge_local_micro”:null,“qualified_impressions”:null,“follows”:null,“app_clicks”:null,“retweets”:null,“likes”:null,“engagements”:null,“clicks”:null,“card_engagements”:null,“poll_card_vote”:null,“replies”:null,“url_clicks”:null,“billed_engagements”:null,“carousel_swipes”:null}}]},{“id”:“8vopl”,“id_data”:[{“segment”:null,“metrics”:{“impressions”:null,“tweets_send”:null,“billed_charge_local_micro”:null,“qualified_impressions”:null,“follows”:null,“app_clicks”:null,“retweets”:null,“likes”:null,“engagements”:null,“clicks”:null,“card_engagements”:null,“poll_card_vote”:null,“replies”:null,“url_clicks”:null,“billed_engagements”:null,“carousel_swipes”:null}}]},{“id”:“8voft”,“id_data”:[{“segment”:null,“metrics”:{“impressions”:null,“tweets_send”:null,“billed_charge_local_micro”:null,“qualified_impressions”:null,“follows”:null,“app_clicks”:null,“retweets”:null,“likes”:null,“engagements”:null,“clicks”:null,“card_engagements”:null,“poll_card_vote”:null,“replies”:null,“url_clicks”:null,“billed_engagements”:null,“carousel_swipes”:null}}]},{“id”:“8weg9”,“id_data”:[{“segment”:null,“metrics”:{“impressions”:null,“tweets_send”:null,“billed_charge_local_micro”:null,“qualified_impressions”:null,“follows”:null,“app_clicks”:null,“retweets”:null,“likes”:null,“engagements”:null,“clicks”:null,“card_engagements”:null,“poll_card_vote”:null,“replies”:null,“url_clicks”:null,“billed_engagements”:null,“carousel_swipes”:null}}]},{“id”:“8vq0d”,“id_data”:[{“segment”:null,“metrics”:{“impressions”:null,“tweets_send”:null,“billed_charge_local_micro”:null,“qualified_impressions”:null,“follows”:null,“app_clicks”:null,“retweets”:null,“likes”:null,“engagements”:null,“clicks”:null,“card_engagements”:null,“poll_card_vote”:null,“replies”:null,“url_clicks”:null,“billed_engagements”:null,“carousel_swipes”:null}}]}],“request”:{“params”:{“start_time”:“2017-06-26T21:00:00Z”,“segmentation_type”:null,“entity_ids”:[“8vn7r”,“8vnbl”,“8voev”,“8voft”,“8voge”,“8vohq”,“8vopl”,“8voqr”,“8vq0d”,“8vq8g”,“8wczv”,“8weg9”],“end_time”:“2017-06-30T21:00:00Z”,“country”:null,“placement”:“PUBLISHER_NETWORK”,“granularity”:“DAY”,“entity”:“CAMPAIGN”,“platform”:null,“metric_groups”:[“ENGAGEMENT”,“BILLING”]}}}


#4

Hi

You’re are requesting stats for the “Twitter Audience Platform” If you’re running your campaigns only in twitter platform, it’s normal if you don’t have results.

Thanks!


#5

Hi Hector,

We are running campaigns both in Twitter and Twitter Audience platform.
While we have statistic in Twitter Ads cabinet, we’re receiving nulls in API.

We didn’t have this problem before while using API with same accounts.


#6

Could you share an screenshot with that data in the same time-window? (include the time window in the screenshot)

If you want remove the critical data of your account (costs for example)

Thanks!


#7

Hi Hector,

Thank you for your help. We were sending requests to TAP, changing it to MAP helped, now everything works. But, we still can’t request all the data from Twitter and Map at the same time.

Here’s what we get:

‘code’ => ‘INVALID_PARAMETER’,
‘message’ => ‘Expected value in ALL_ON_TWITTER, PUBLISHER_NETWORK, got “ALL_ON_TWITTER,PUBLISHER_NETWORK” for placement’,
‘parameter’ => ‘placement’,
),

Any thought on how to combine twitter and map reqeusts?


#8

You can’t, you should do it separately