Getting null for billed_charge_local_micro field in GET stats/accounts/:account_id request


#1

Here’s the request I’m trying to make:
https://ads-api.twitter.com/2/stats/accounts/18ce54f05w5?entity=LINE_ITEM&entity_ids=770m7&start_time=2017-01-01&end_time=2017-01-03&granularity=TOTAL&placement=ALL_ON_TWITTER&metric_groups=BILLING

I can see on my dashboard that this line item has spend for this same time range, however I get the response:

{
    "data_type": "stats",
    "time_series_length": 1,
    "data": [
        {
            "id": "770m7",
            "id_data": [
                {
                    "segment": null,
                    "metrics": {
                        "billed_charge_local_micro": null,
                        "billed_engagements": null
                    }
                }
            ]
        }
    ],
    "request": {
        "params": {
            "start_time": "2016-12-31T22:00:00Z",
            "segmentation_type": null,
            "entity_ids": [
                "770m7"
            ],
            "end_time": "2017-01-02T22:00:00Z",
            "country": null,
            "placement": "ALL_ON_TWITTER",
            "granularity": "TOTAL",
            "entity": "LINE_ITEM",
            "platform": null,
            "metric_groups": [
                "BILLING"
            ]
        }
    }
}

Any idea why this could be happening?


#2

disregard this.i found the issue. i was using ALL_ON_TWITTER instead of PUBLISHER_NETWORK. i thought the first included the second


#3

Thanks for taking the time to update the thread, @eepranskee!