Getting error - "Sorry, that page does not exist" on regenerate access token and secret

oauth

#1

Whenever i am trying to regenerate my access token and secret from “Keys and Access Tokens” page in my app settings, i am getting error “Sorry, that page does not exist”.


#2

Thanks for the report, investigating.


#4

Did you have suggestions to my problems, actually i am getting those errors on twitter apps site. I can not do anything to resolve it. Please help!


#5

We are continuing to look into this, unfortunately we cannot offer a workaround or resolution at this time.


#6

I also observed some strange redirection to the mobile.twitter.com whenever i am trying to access it from Chrome. May be that could be the reason, can you provide my any testing access tokens and access secret from my account so that i can at-lease continue checking APIs.


#7

I am having the same issue. Any word on a fix yet?


#8

Did you found any fix for the issue?


#9

At the moment we are still working on the issue.


#10

Can you please provide me any time when i can expect it to be resolved, its have been weeks and i really need to get this done.


#11

Did you found any resolution for this.


#12

I’m unable to say when the “regenerate” button will be fixed correctly, but a workaround is to click on Revoke Access to go into the Twitter account settings for the account authorised to the app, revoke the permission for the app, return to apps.twitter.com (where the tokens should now be blank) and click Create my Access Token. There may still be a “page does not exist” banner, but the tokens should be generated successfully.


#13

Yes, i tried doing that but i got following error on using tweet update api (https://api.twitter.com/1.1/statuses/update.json?status=Maybe%20he'll%20finally%20find%20his%20keys.%20%23peterfalk)

{
“errors”: [
{
“code”: 32,
“message”: “Could not authenticate you.”
}
]
}

i am using api referance from:
https://developer.twitter.com/en/docs/tweets/post-and-engage/api-reference/post-statuses-update

i used oauth 1 as my authentication method and checked all four params( Consumer Key, Consumer Secret, Access Token, Token Secret) four times, i have put them correctly but still getting errors on api calls.

there is one more strange behaviour in APIs, With same tokens i am able to call timelime api (https://api.twitter.com/1.1/statuses/home_timeline.json), i got data successfully with the generated tokens this time.

please advice if i am calling something wrong while post tweet API.


#14

What are you using to call the API? Have you tried using twurl?


#15

No, i have not tried twurl, i am using through REST api app (Postman). should i try twurl?


#16

I used twurl and it worked, but how can i use it in my application, i am using PHP to achieve this.


#17

I’d recommend using an existing PHP library for the Twitter API such as @abraham’s TwitterOAuth - it should make the authentication much simpler for you.


#18

Yes, That worked, using PHP library and i am able to post tweet successfully, but i need any Javascript library which implements Oauth 2. please suggested me any such library.

Also there is one query, why i am not able to to call apis from rest api app(like postman), and That “Page not found” error, is that okey to ignore it and implement any third library like the PHP one. please suggest.


#19

Please suggest if i can use this PHP library and ignore “Page not found” error.


#20

You can ignore the page not found error. Feel free to use any PHP library you choose.


#21

I am getting this same error when I try to generate new tokens. I created four new APIs and each got a Page not Found. I did what was suggested–deleted the existing permissions and then regenerated the access keys and the tokens. I still get the mysterious page not found error. When I refresh the page, all seems well and I enter the new keys and tokens into the WP Twitter Pro plugin in my websites. They all connected successfully and I start getting a feed. But after a while, in place of the feed, I get “Error: Could not authenticate you.” for three of them. When I went back to Manage the APIs, it says three of my APIs are suspended. There is nothing that says why.