Getting error message: "This application cannot authenticate more users at this time"


#1

Hi guys,

Have been using the OAuth flow for a while now in our application, but since today we’re starting to get the error message: “Sorry, please try again later. This application cannot authenticate more users at this time.” We’re definitely not near the 100.000 token limit… Someone else tried and got a full-page Twitter error message saying “Something went wrong.” Are there any known issues on OAuth at the moment on your end?

Also, is the limit for Basic access OAuth tokens lower than 100.000? And if so, is this limit documented anywhere? Lastly, is there a way to revoke access tokens?
Thanks,

Tiana


#2

Hey Tiana. Sounds like something strange is going on, but I’m not aware of any generic issue with OAuth on our side at the moment (that’s not to say there isn’t one - just that I haven’t heard of one!)

The token limit is unlikely to be an issue here since it only applies to apps reproducing the Twitter client experience, and as you say, you’re probably not close to it. Checking on that requires sharing app-specific information like the App ID / name / access tokens so we can’t help with that via the forums (you can open a Platform Support ticket to ask for assistance).

There’s no different limit for “basic access” (I assume you mean read-only?) tokens vs any others. Again, the 100k limit is only applicable to a small category of apps that use the API. What kind of things is your app using the API for?

The only way I know of to revoke tokens from the perspective of an app developer is the somewhat “nuclear” option of regenerating app key and secret - which would have the effect of requiring all auth’d users to login again.


#3

Hi @andypiper

Thank you so much for the reply! I will open a Platform support ticket and update this forum post with any answers.

Haha, that indeed is quite nuclear. :smile: A way to revoke tokens as app developer in a slightly less nuclear way would really be awesome. I will however discuss whether this might be something we could do in a little while. :wink: Thanks!


#4

Hi again @andypiper,

Any idea how long until Platform tickets are looked into? I sent in a Platform support ticket on this last week, but still haven’t received an answer… We’re still experiencing the issue though, our users can’t login using Twitter. General issue number: 27176057


#5

We have the same problem and I’m unable to submit a support ticket (which I guess looking at above comments isn’t something that helps anyway). How do I sort out this problem?


#6

We have an issue with our platform support forms submissions at the moment, working to resolve.

This should not be happening - what’s the app ID (the number from the URL on apps.twitter.com)


#7

Thanks for such a prompt reply. The app id is 6312199


#8

Probably not appropriate to debug this in the forum, I’ve just followed your account on Twitter for DM conversation to check a couple of details. If you can follow me back I’ll see what we can do until we get the form fixed and take this down a regular support channel


#9

Hi team,

We are also getting the same error message: “Sorry, please try again later. This application cannot
authenticate more users at this time.” We’re definitely not near the
100,000 token limit.

Please suggest a solution for the same.

Thanks,
Rahul


#10

Is this an Ads API application?


#11

I am having the same error


#12

Can you provide example code? What kind of application is this? Are you using the Ads API?


#13

i am using REST Api, OAuth1, i haven’t even exceeded 10 access tokens, i am using yii2 authclient for authentication


#14

What endpoint are you calling? Has your app ever been granted access to the Ads API?


#15

@Omar_Mohamed_33 are you able to provide an update on this? thank you.


#16

We are having the same issue with an app for which Ads API has been recently enabled. Not all the users are having the issue, e.g. my personal username @frangarcia is able to authenticate properly (be aware that I had already authenticated my account against this app previously) but a brand new username @frangarciawi just created this morning is not able to authenticate and I get the error

The application cannot authenticate more users at this time

Definitely, is not only affecting brand new accounts as I have some other twitter users complaining about not being able to authenticate and I have just checked they are old twitter accounts.

I have just followed you in case you need more details via DM.


#17

For the Ads API, depending on your level of access, you’re limited to the number of user tokens that can be authenticated. This is described in the documentation - developer level gets 5 tokens, basic 15, and standard is not restricted. You should work with your Ads API contact on this.


#18

I’m having this issue for an app that has recently had the Ads API enabled. We tried to Oauth authenticate another user account for ad reporting and received this message.

We worked withour Twitter rep, but they asked us to submit via the Ads Help. How do we determine who our Ads API rep is who can help with this?


#19

I’m seeing this issue today. First time I’ve seen it for our app. I think our app has very few users. It is happening with an app that we have registered with Gnip. Maybe that has something to do with this?


#20

There should not be any token limit associated with having an app having access to Gnip APIs. Have you ever applied for access to the Ads API?