Getting blank embed codes


#1

Trying to embed tweets for a blog post. Getting blank embed codes whenever I hit embed on all tweets on my laptop and my desktop. Anyone else having this problem?


#2

Can you share the embed code? Are you able to reproduce the issue outside of your CMS?


#3

I can copy the link to a tweet perfectly fine, but nothing happens when I try to get an embed code, it’s just blank.


#4

Which CMS are you using to try to display a Tweet? When you visit the Tweet URL in your browser, does the Tweet still exist?

A blank Tweet display is the expected result when the Tweet has been deleted from Twitter.

A typical oEmbed flow will include a HTML blockquote element and a script element in the response. The blockquote displays the text of the Tweet, author information, and a timestamp. The script element returned enhances the blockquote with a full embedded Tweet display.

Assuming your CMS successfully handled fetching the appropriate HTML for the Tweet URL, it’s possible your CMS stripped some or all HTML before outputting the final webpage. View source of the resulting web page (public, not admin) and search for twitter-tweet to find the blockquote HTML element which should be output with the page.


#5

Yeah, everything else seems totally normal. I’m just on safari and when I copy and paste the link of the tweet in my browser the tweets are all there. It’s not a one off issue, it’s every tweet in my feed. And it’s just me, I sent the tweets I needed to embed to my sister, who was able to get the embed html codes and send them to me in an email so I could make my post.

I’m ultimately using Google Blogger, but I’m not even getting to that point. The embed codes aren’t being generated from the tweets on my timeline.


#6

I am also getting this problem. The box where the HTML code normally appears is just blank. I’ve had this issue before. I’ve tried to get embed code in Safari, Firefox, and Chrome. Other users are able to get the embed code for the tweet. I have pasted in the HTML code another user generated for me, and the embedding appears to work in this forum.

Watch Matt Boyd stun Joey Gallo with this big hook for the backwards K (Thanks to @tejasxb for the request!) pic.twitter.com/ZmhYvYCrye

— Pitcher List (@ThePitcherList) June 27, 2015

#7

Hi,

I am also getting this problem across all browsers (see image below). I am currently using a computer at work and every tweet I try to embed has a blank embed code. The person who sits next to me signed into Twitter on this machine and had no issue. I haven’t changed my browser settings - any idea on what’s happening?

I’m a journalist, so embedding tweets is part of my job. I’d really like to resolve this issue. My company’s IT department has looked at the machine which they say is fine and they suspect it’s related to my Twitter account. Any and all advice/tips would be welcome.

Thanks,
Danielle


#8

Did you ever figure this out. The same thing is happening to me!


#9

Hi,

I am yet to work out what is happening or how to fix it. Does anyone else know what the issue is?

Thanks,
Danielle


#10

Im in your boat too. Im a journalist too. This is very frustrating.


#11

Here is what I’m getting


#12

Me too:


#13

Hi,

It also doesn’t matter who wrote the tweet or how old it is:

Cheers,
Danielle


#14

I did not figure out how to fix this problem or why it is happening. My short term fix was to create a dummy twitter account and get the embed codes from there haha.

I’d say a day after I had the problem with embed codes it just all of a sudden started working again. Then last night I started to have the same issue and I’m back in the same boat.


#15

NO EMBED CODE IN COPY FIELD! Tried in several browsers across multiple desktops. Nothing. PLEASE FIX!


#16

Hi,

I also use tweet deck and it seems I can pick up the embed codes there. But I’d still like to resolve this issue - if anyone from Twitter knows how, I’d be grateful.

Thanks,
Danielle


#17

I am experiencing the very same problem most others have described here – a blank embed code. On both my laptop and my desktop… a frustrating problem as I frequently embed tweets as part of my job.


#18

I getting the same problem and we don’t have answer yet.


#19

I’m having the same problem - in Safari and in Chrome on a Mac. It started in Safari and I was using Chrome to workaround, then it stopped working in Chrome as well. Is there a better workaround? Tried clearing cookies, restarting etc.


#20

It’s also happening in Firefox. Refreshing doesn’t help, nothing helps.