Getting an "Invalid card type" error in validator - all meta tags appear to be correct


#1

I’ve added what I think are the correct meta tags to my site, but am getting an error in the validator.

Here’s the URL I’m running through the validator: http://www.raptorsrepublic.com/2013/10/09/practice-recap-valanciunas-english-cumulative-talent-ross-laid-back/

Here’s a screenshot of the error: http://i.imgur.com/eKIVQvQ.png

Here are the twitter-related meta tags in the page:


#2

Thanks for reporting, we will investigate.


#3

I’m getting like this too. ( example’s URL: http://www.dek-d.com/activities/33117/ )
Please help.


#4

Also getting this error today.

Sample URL: http://www.misterjonjon.com/2013/10/singtel-globe-samsung-partnership.html
Sample Tweet: https://twitter.com/jonjongoco/status/388172827666296832


#5

Please Help. I add the correct meta tags but am getting an error un validator http://www.diariodebolsillo.com.pa/node/904


#6

Same here
My photo card was working fine till few hours ago, suddenly no twitter card is displayed and when i tried the validator it says error although nothing has changed in the meta tags!

My website is:


#7

its working now on twitter

I think the issue is gone and the card is back to normal but still some problem with the validator that should be fixed


#8

I’m seeing this issue too - the validator is reporting “Invalid card type.” for sites that definitely have correct meta data, eg. NY Times (sample URL: http://dealbook.nytimes.com/2013/10/03/twitter-discloses-its-i-p-o-plans/)


#9

Nope, still not working for the case described in this ticket.


#10

Thanks for the responses and issues raised. Our fetcher was on the fritz on and off in the last 24 hours. It’s mostly OK.

@raptorsrepublic, I’m still seeing the same issue for you. I’ll keep investigating your particular case.


#11

The validator allows me to request an approval now but it is automatically rejected by email ?
I don’t have any idea to do now.

example’s URL:



http://writer.dek-d.com/puntanan/story/view.php?id=884612


#12

It’s happening to me as well

Invalid card type.


#13

@raptorsrepublic,

Can you try adding this to your page and trying again?


#14

Sorry, adding what to my page?


#15

Sorry go to this page and look for the META tag with Content-Type

https://dev.twitter.com/docs/cards/troubleshooting


#16

Thanks for the tip. I updated the code and tried the validator again, still did not work and getting the same error. Would it be worth mentioning that the site is hosted in Germany with Hetzner?


#17

Resolved. Thanks!


#18

Hi Stephen!

Do you know what specifically worked, so others can try the same thing? (Or was it just re-trying?)

Thanks!


#19

It looks like this instance works. Please feel free to try again.


#20

After some heroic investigation on our engineering side, we found what might be the cause.

It turns out, our fetcher does some canonization of URLS, transforming http://www.raptorsrepublic.com/2013/10/09/practice-recap-valanciunas-english-cumulative-talent-ross-laid-back/ into http://www.raptorsrepublic.com/2013/10/09/practice-recap-valanciunas-english-cumulative-talent-ross-laid-back (Note the missing trailing slash on the second one.)

When I type the above no-trailing-slash URL in a browser, I get an empty page. Hence, the “Invalid Card type”.

I also noticed that you’re hosting a WordPress site. When I look at other Wordpress sites, I see it handle the no-trailing-slash gracefully by redirecting to the trailing slash version. Here are some examples:


http://snoopdogg.com/2013/10/15/nemo-hoes-interviews-rob-dyrdek-on-the-new-ggn

Again, all redirect to the same URL with a trailing slash.

I can ask the engineers to take a look, but I know that may take some time. So I wonder, do you happen to know why your WordPress site is different than other ones, and is there something different in the configuration we could change to have it gracefully redirect like other wordpress sites?

Know it’s maybe not the most helpful, but I want to get you up and running soon – know you’ve been patient.

Thanks a ton!