Getting a code 34, all signs point to a Twitter API bug


#1

I have been using Abraham Williams’ PHP oAuth libs for about 3 years with no problems, recently, I started getting an error 34 (Sorry, that page does not exist).

Specifically, this is for the users/lookup call:

$connection = new TwitterOAuth($twitterKeys[‘consumer_key’], $twitterKeys[‘consumer_secret’],$twitterKeys[‘oauth_token’],$twitterKeys[‘oauth_token_secret’]);
$results = $connection->post(‘users/lookup’, array(‘user_id’ => ‘102875024,857327942,463466897’));

This gives me error 34.
$results = $connection->post(‘users/lookup’, array(‘user_name’ => ‘some_name,someother_name’));

Gives me the profiles I requested.

I even tried the oAuth request tool (https://dev.twitter.com/docs/api/1.1/get/users/lookup). I copied the cUrl command it generated and used it. It worked when I used screen_name, but when I used user_id, it produced the dreaded error 34.

Before you give me suggestions, can you please try it on your own? If this is a confirmed bug, what’s the timeline for having it fixed?


#2

I cannot reproduce. What’s an example user ID or set of user IDs you’re passing when this happens? if none of the user IDs specified match actual user accounts, a 404 with error 34 will be thrown. Be sure that your commas are being encoded correctly as well.


#3

Did you try reproducing it using Abraham Williams’ library?


#4

No, I tried reproducing by interfacing with the API through the thinnest possible tool.

On second glance, one problem you might be having is that you’re using a user_name parameter when you probably mean the “screen_name” parameter.


#5

screen_name vs user_name is not the issue here. It’s a typo, and I said in my post that the issue is use of user_id with Abraham Williams’ library. As mentioned in my post, I also tried it using the thinnest possible tool: the Twitter API’s own oAuth request generator.