Getting 404 Not Found error constantly


#1

Hello,

I am facing this problem since few days ago.

When I POST to [https://api.twitter.com/oauth/access_token], I get 404 Not Found error.
Sometimes it works, but in most cases it fails.

Even though sometimes I succcess to get response from oauth/access_token,
I get error on the next step (mostly, POST to http://api.twitter.com/1/statuses/update.json)

My request is something like:

POST https://api.twitter.com/oauth/access_token HTTP/1.1 Host: api.twitter.com Content-Length: 80 Content-Type: application/x-www-form-urlencoded Authorization: OAuth ......

The response from the server is as follows:

HTTP/1.1 404 Not Found Date: Wed, 28 Sep 2011 02:21:18 UTC Server: tfe

I have tried this with SSL and without SSL. In both cases the problem consists.

My application is developed using xAuth.

Is there any workaround for this?
And could you tell me about what ‘Server: tfe’ stands for?


#2

Thanks for the report, we’ll look into this.

TFE is a type of web server we use here at Twitter.


#3

@dscape_d Hey JinHui - can you alter the body of your post request to:

POST /oauth/access_token ...

instead of

POST https://api.twitter.com/oauth/access_token


#4

@episod Hi Taylor, thanks for your reply.

Today, I ran the same code with the same parameters and it worked!
I didn’t modified my code. The twitter server now doesn’t complain about my request.
Maybe it was a passing phase.
Strange thing is, while my code using twitter API was not working, the official twitter app from my iPad just worked as well. There maybe some difference between xAuth and oAuth, I guess.

@dtran320 Hello David.
I tried:

POST /oauth/access_token ... and is working as well. For I am seeing no error today, I will try your suggestions if I get the errors again.

Thanks for your reply.


#5

Sorry to dig up a thread 9 weeks old, but I’ve been getting this again. For me, the issue appears to be DNS related where the IP I’m getting for api.twitter.com was resolved (from UltraDNS) to an IP that wasn’t approved by the SSL certificate. Hard-coding the IP, and eventually switching to another DNS server, fixed this issue for me.


#6

Happening to us as well, 404ing all my requests for Twitter >_<


#7

same thing happens to me when i click on my profile it says Sorry, that page doesn’t exist!

Thanks for noticing—we’re going to fix it up and have things back to normal soon. and my mentions too dont work…please help me…am really frustrated


#8

error 404 is really worrying me pls help me


#9

i am also getting this all of a sudden: Request C83EE2E1-60EE-4DB0-86C1-E151C69F18E4 failed with error: Error Domain=HTTP Code=404 "The operation could not be completed. (HTTP error 404.)"
Please help


#10

Hi,

I am facing the same 404 error. We have iPad app where we have implemented oAuth and we are trying to make a call to the following urls

https://twitter.com/oauth/request_token
https://twitter.com/oauth/access_token
https://twitter.com/oauth/authorize

We are continuously getting this 404 error please help me too!!


#11

You’ll need to upgrade your application to use the correct URLs.

In the case of API resource URLs, you want URLs that look like https://api.twitter.com/1/users/lookup.json

In the case of OAuth negotiation URLs, you want URLs that look like
https://api.twitter.com/oauth/request_token


#12

yes, thanks @episod

Replacing: #define TWITTER_DOMAIN @“twitter.com

With: #define TWITTER_DOMAIN @“api.twitter.com/1

in MGTwitterEngine.m posts the messages as usual…


#13

Is this change done for the new REST API 1.1 or for version 1


#14

works for me thanks thanks


#15

thanks it’s working now. i have one doubt again this error come? and then i ak one question, i have twitter api for followers id the url is https://api.twitter.com/1/followers/ids.json?cursor=-1&screen_name=twitter_api. how to fetch data from this url by using oauth method. pls help me.


#16

I need to integrate api.twitter.com/1.1/statuses/user_timeline using MGTwitterengine.In the previous version it has been worked.Now i have changed version 1.1 still it’s not working.Any suggestions please…


#17

I believe that now we have to do TWITTER_DOMAIN @“api.twitter.com/1.1” ?

Also I can post a tweet without any error using the above but getting 404 while using getFollowers.