Getting (401) Unauthorized while trying to login and used to work perfectly fine


#1

My website TweetMyMIxtape.com use to login with no issues at all and today I started getting (401) Unauthorized and no one can login to the website. I checked my app status and there is no issue with it. Any idea why this is happening it seems to be happening with a few other sites just like mine but not directly linked with me. They belong to other owners. Any idea why this issue is starting right now?


#2

I have a same problem. My application works perfectly again yesterday via API.
Now and for a few hours, I get an error 401.

I change oAuth Token key and secret key on my api and software application, I have already same error on “Get Authorization Link” section…

After some search, I’m not sure but I think problem is Oauth version. y application use actualy .net dll (TwitterVB2). I try with other library (Flurr.dll) but result is same >>> 401 error

:frowning:


#3

I’m having the same issue with my site that used twitter authentication for the users, since a few hours the site throws a Twitter EpiOAuth exception. I’m using the jmathai async twitter php class (https://github.com/jmathai/twitter-async). I haven’t changed anything in the code on the site, it has worked before for many months, so i’m assuming it’s something on Twitter’s side? Has anything changed overnight in the authentication process?


#4

Seeing the same for one of my apps too, using DotNetOAuth on our side to login the user using their twitter ID (read-only access). response is 401 Unauthorised, used to work fine.


#5

I have the same problem :frowning:


#6

I also have the same problem. I’m using the Epi Twitter PHP library and as of yesterday our twitter login functionality on our site stopped working…

ps: I changed the paths to twitter from ‘http’ to ‘https’, it didn’t solve the problem…


#7

Exactly, I have the same problem from yesterday I’m using PHP and library “Twitter Async” http://wiki.github.com/jmathai/twitter-async

:frowning: … and the error is:

exception ‘EpiOAuthUnauthorizedException’ in /home/joanizqu/apitwitter/EpiOAuth.php:404
Stack trace:
#0 /home/joanizqu/apitwitter/EpiOAuth.php(376): EpiOAuthException::raise(Object(EpiCurlManager), false)
#1 /home/joanizqu/apitwitter/EpiOAuth.php(39): EpiOAuthResponse->__get(‘oauth_token’)
#2 /home/joanizqu/login_twitter.php(21): EpiOAuth->getAuthenticateUrl()
#3 {main}


#8

I have spent half a day on this. So far no luck. My app is making a request to:
https://dev.twitter.com/docs/api/1/post/oauth/request_token which says:

  1. Authentication is not required
  2. equal for both versions of API (1 and 1.1) so any API changes shouldn’t affect it

However the requests have started to return “401 Unauthorized”

When debugging I added authorization and using this tool:
dev.twitter.com → My applications -> oAuth tool -> See oAuth signature
I made sure the authorization of my app returs the same signature. But twitter still gives erros :frowning:


#9

However for me changing the request url from http to https solved the problem. Thanks @tomanthoni for the idea!


#10

Ours was always https, so that isn’t going to help. Anyone at all find a fix for this yet. We are still looking to figure this out. Makes no sense it suddenly stops working after months of no issues.


#11

@tweetmymixtape exactly, same problem. I use an tiers library to connect my software to use twitter… so http or https, it’s not me to indicate url link :frowning:


#12

Make sure you’re pointing at https://api.twitter.com/oauth/* for all OAuth operations. twitter.com/oauth/* has been deprecated for some time.


#13

Yeah, if anyone finds a solution, please share, our website is placed ‘under maintenance’ because of this… :frowning:


#14

Question: my application runned since 1 year with no problem so why, today, It’s not possible to use it ?


#15

Thnks @iAmJuhan @tomanthoni … It’s incredible! Now this works with https. I can not believe but thanks.


#16

You’ve been using the wrong path for all that time. Yesterday we stopped allowing non-SSL based requests to this already deprecated URL.


#17

Does anyone know how to check the api time - I saw someone said it could be that but how do we check that?


#18

Yea i changed it to that and unfortantely still no good. The error I am getting is this - Failed to validate oauth signature and token


#19

2/20/2013 10:59:30 AM
Post URL:
https://api.twitter.com/oauth/request_token?oauth_callback=[URL]
Post Data:
oauth_consumer_key=[CONSUMERKEY]&oauth_nonce=6728830&oauth_timestamp=1361375970&oauth_signature_method=HMAC-SHA1&oauth_version=1.0&oauth_signature=HEUdEoYx63IGWjx0Nl9WNucy26g%3d
that is what we are posting


#20

The API responds with its current time in the “Date” HTTP header of every response