Getting 401 Authorization Required last couple of days


#1

I started getting 401 errors. I can duplicate the problem here…

https://dev.twitter.com/oauth/tools/signature-generator/1812246?nid=672

Using the signature generator, I generate the request then use the curl command line, curl returns with the 401 response.

This is the endpoint that is returning the errors…

https://api.twitter.com/oauth/request_token

To duplicate the problem this is what I am doing…

  1. Go to…
    https: // apps.twitter.com/app/1812246/permissions
  2. Click “Test OAuth”
  3. Change the Request URI to…
    https: // api.twitter.com/oauth/request_token
  4. Click “Get OAuth Signature”
  5. Copy the curl command
  6. Paste the CURL command into the console

I have tried the curl command from Linux, 3 different Amazon EC2 Libux instances, I have also tried it from my OS X Workstation.

I added spaces to some of the referenced URL’s twitter didn’t like any more than 2 URL’s


#2

Perhaps my request for help isn’t clear or perhaps it is in the wrong place. Is there a way to notify someone from twitter that the signature generated from their signature generator isn’t autheticating when using the curl command they suggest.

I have been successful at making requests to the twitter API in the past but they have just recently started failing. Is there a better place to post my question/request for help?


#3

I’m having the same issue here with a new test application that I have created to test the Twitter API for implementation into an application I am building that will consume the streaming API