GET scoped_timeline


I have a trouble when getting scoped timeline.

I followed


twurl -H “/0/accounts/ftr8ac/scoped_timeline?as_user_id=95671956”



I don’t know why the return of data was empty. Actually, my timeline still have tweets.
I need your help !!!


Your first issue is you are using as_user_id, which is not an accepted parameter on that endpoint, so that just gets ignored. You should be using user_id.

Running the same twurl request but using user_id instead does not get you the results you expect either though:


twurl -H "" "/0/accounts/ftr8ac/scoped_timeline?user_id=95671956" | jq .


  "errors": [
      "code": "INVALID_PARAMETER",
      "message": "Expected user ids to be promotable users, got \"95671956\" for user_ids",
      "parameter": "user_ids"
  "request": {
    "params": {
      "user_id": "95671956",
      "account_id": "ftr8ac"

You should read up on what a promotable user is, which also covers how to check promotable users available to an Ads account, if this is not clear to you.


So sorry about my silly mistake.
I tried again with twurl request and used correct user_id but the result still was empty.


twurl -H “” “/0/accounts/ftr8ac/scoped_timeline?user_id=956971956”



I got user_id from the link mentioned above.


twurl -H “” “/0/accounts/ftr8ac/promotable_users”



Sorry to bother you. I’m looking forward to hearing from you again.


No worries at all @themoon287 - and no need to apologize!

From the looks of things, 956971956's Tweets are protected, which I believe is the reason behind this. Try this endpoint with a promotable_user whose Tweets are not protected.

POST promoted_tweets

If you have a look at this page on “About eligibility for Twitter Ads”, under the Overall Account Status section you will find the following quote:

Protected Tweets - Twitter users can protect their Tweets in order to control who can view them. This setting is not currently supported within Twitter Ads. If your Tweets are protected and you are interested in advertising, you will first need to make your Tweets public from your Settings page.


I have got it. Thank you so much ! :slightly_smiling: