Georss error in atom search with lang:nl option


#1

when i run this qeury:

http://search.twitter.com/search.atom?q=omo+-wast+-wasmiddel+-reclame+%23omo+lang%3Anl&rpp=10

i get the error about an undefined namespaceitem georss

This query worked until today. What can be wrong?

thanks in advance

greetz

Robert van Oort


#2

Hi Robert,

Looking into this for you.


#3

Thanks


#4

Really keen to understand whats going on here:

Some atom queries provides a “Feed Code Error”, which almost always seem to be a "Reference to undeclared namespace prefix: ‘georss’ " error, for example http://search.twitter.com/search.atom?q=adelaide

Yet other quries of exactly the same type and format seems fine, for example http://search.twitter.com/search.atom?q=sydney

What is causing this?


#5

The issue is that the namespace declaration for georss is only present with place-related data is associated with a tweet in the response. The problem that’s happening is that the namespace declaration isn’t happening at all. Until this is fixed, you could mitigate by first munging the raw XML response you get back and adding the namespace declaration before parsing or instruct your XML parser to be more lenient. Hoping to get this fixed early this week.


#6

How will we know when this is fixed?


#7

We’re hoping to have this resolved by the end of the week, if not sooner. You’ll know it’s fixed when you no longer encounter the namespace missing exception when the response contains references to that namespace.


#8

We believe this issue to now be resolved. Please let us know if you continue to experience it.


#9

#10