Geo: null in all search api results



I made a small app which fetches users’ geolocation data and displays recent tweets within 100 miles of radius. The query is something like this:,long,100mi&result_type=recent&count=100

App link:

Previously I was getting results close to 100, but now the count has dropped drastically to around just 2-3 results.
I tried changing result_type=recent to popular, and even then the results were same.

Geocode: Still getting very sparse results

For all the results the “geo” key has value null.
Is it deprecated?


@andypiper can you look into this issue?

Previously I was getting geo: null in just 5-10 tweets at max but now I’m getting it for almost all the tweets.
App code:

Thanks in advance!


I’m having the same issues.

GET search/tweets using the ‘geocode’ parameter looks like it works ‘normally’ more often when searching with a smaller radius. For example 1km in major cities

By normal, I mean only geotagged tweets are returned with longitude and latitude values under the geo key - this is how it’s been working for ages.

Higher radiusus for whatever reason seem return all tweets with ‘null’ for geo keys and instead defaulting to the user’s location.

I really hope this is a bug that can be fixed, rather than a change in how geo tweets are being returned using ‘geocode’. For my project, it won’t be feasible to loop through thousands of non geo-tagged tweets just to get a handful of ones that are geotagged.

You can see the issue I’m getting at (JS console shows tweet objects before error)

Any info/help appreciated

Thanks :slight_smile:


I’m having the same problem, as posted in : GEO search returning very few results


Me too. This a huge annoyance since I turned in a project thats focus was using this data.


I am having the same exact problem. I’m hoping we can get somebody from twitter to at least acknowledge this.

Twitter search api always return geo="<null>"

+1 I’m having the same exact issue. Right now my app ( is basically unusable :-/

Anyone have some workaround for this issue? That’d be greatly appreciate!


A few people were saying to minimize the amount of miles to get more tweets and I ended up getting instead of 3, about 8 or 10, but I need around 100 for my app to work properly. The only way to get a lot is minimize the miles between 1-4ish and that solves the issue but kind of defeats the purpose for me. Also, the Twitter API Console Tool has been down for over a week so it makes it that much harder to test what data I’m getting.


The same happens to me. One of the features of my app ( is to search tweets and position them on a map. Right now this feature shows very few results.


The Console is an embedded widget provided by Apigee. FWIW, it is loading for me at the moment, but I’ve sometimes seen issues where it doesn’t render on different networks. I’d strongly recommend that you use our twurl command-line tool instead, as it provides better access to all of the different API endpoints.


Still having this problem - can someone from twitter at least acknowledge the geo results problem?


Same problem here.
I’m getting “geo: null” and the only information relationated with geo is the object ‘place’, but the information contained in is irrelevant for obtain the coordinates of the tweet.
Anyone has solved this issue?


So should I continue as if this isn’t getting fixed? This lack of support is extremely frustrating and disappointing and I’ll definitely think twice about using Twitter’s API again.