Gender criteria lacks documentation and doesn't not seem to work through the API


I have created a gender criteria with the endpoint ( ). The post params looks like this:

   line_item_id:  "42hmc"
   targeting_type: "GENDER"
   targeting_value: 1

Then when I export the corresponding campaign from the ads editor. I see that the GENDER targeting stays ‘ANY’. I checked that the targeting_criteria was created and that its value was ‘1’.


Could you have a look at our Guidelines for Reporting issues and provide us with all the relevant information?

For example, what does your request look like? What kind of response do you get back? When you make a subsequent request to the API to get your targeting criteria, what do you get back?

For example, if I do the following:

twurl -H -X POST -d "targeting_type=GENDER&targeting_value=1&line_item_id=cc4e" /0/accounts/gq10e8/targeting_criteria | jq .

The response I get is as follows:

  "data_type": "targeting_criterion",
  "data": {
    "line_item_id": "cc4e",
    "name": "Male",
    "id": "338ym",
    "account_id": "gq10e8",
    "created_at": "2016-01-13T14:20:19Z",
    "targeting_value": 1,
    "updated_at": "2016-01-13T14:20:19Z",
    "deleted": false,
    "targeting_type": "GENDER"
  "request": {
    "params": {
      "line_item_id": "cc4e",
      "targeting_type": "GENDER",
      "targeting_value": 1,
      "account_id": "gq10e8"

So the targeting value is correct and as expected. When I make a subsequent request as follows, I still get the same result and the correct targeting value:

twurl -H /0/accounts/gq10e8/targeting_criteria?line_item_id=cc4e | jq .

Let us know if you are seeing the same behavior from your end - if so, and you are only seeing inconsistencies with what is returned from, then this means it’s a UI-only issue. In such a case, your best course of action will be to click on "Help?" on the top right hand corner within and follow those instructions so you can submit an issue with the UI team.


The APIs are consistent with each other. So yes, it is a problem with the Ads editor. I sent an issue to the UI team.


Great, thanks for doing that Alex!