Fatal: Twittercore framework version doesn't match twitterkit framework version

ios
xcode

#1

Upon integrating Twitterkit framework through Fabric, my app crashes immediately upon launch with the following error:

Terminating app due to uncaught exception ‘NSInternalInconsistencyException’, reason: ‘TwitterCore.framework version (1.15.1) doesn’t match TwitterKit.framework (1.14.6). Please, make sure both kits are up to date.’

This is with XCode 7.2, Fabric 2.1.2 (removed and installed latest version with no change).

The strange thing is that the latest version of fabric is using TwitterKit 1.14.6 when this link https://fabric.io/kits/ios/twitterkit/summary offers 1.15.1

Any suggestions on how I can fix this?


#2

TwitterCore.framework version (1.15.1) doesn’t match TwitterKit.framework (1.14.6) also get this error after integrate


#3

Thanks for the reports both, we’re looking into this.


#4

Probably related: after manually downloading TwitterKit 1.15.0 and updating our app, the Fabric app now complains that I’m not using the latest version, which it says is 1.14.6. Looks like wherever the app is getting its info from didn’t get updated when the new framework was published.


#5

Just as a heads up, we’re working on a fix for this that should go live tomorrow. If you need this in the meantime, downgrading to the previous version of Digits and TwitterCore is the best way to go.


#6