Existing user can’t re-authenticate in app that has exceeded 100,000 users?


#1

Hi,

Today a certain twitter app for Android started having problems, so I uninstalled and then reinstalled it.
However, when I went to the Twitter account authentication page, an error message of the following kind was displayed.

“Sorry, please try again later.
This application cannnot authenticate more users at this time.”

In addition, even when I login from this page’s “Sign in”, I end up being transferred to a similar page.
What exactly is going on here?

I read in the article below that an app that has exceeded 100,000 users cannot add users, but is the system set up so that existing users also can’t re-authenticate?
https://dev.twitter.com/blog/changes-coming-to-twitter-api

This means that if I reinstall an app or switch it to a new device, I will never be able to use that app again.
Could you please look at the specification once more?

If I don’t have this app then my opportunities to look at Twitter will be greatly reduced.

Unfortunately I expect that many apps will be restricted the same way in the future, but would you at least allow me keep using an app that has permitted authentication once?

Oh, dear Twitter, I don’t want you to become evil.


#2

I’m running into the same issue. I’m an existing user for an app, I can see the app in the Applications tabs on twitter. But when I reinstalled the “approved” app on my laptop I cannot authenticate with twitter. I can use the app on my desktop computer however, so I know that that I still have a valid token.


#3

Welcome to the wonderful world of diminished choice.
Twitter’s attitude on this one appears near suicidal. It’s stopped a huge number of apps from being updated because the devs (quite rightly) think “What’s the point?”.

Now that all of those older apps are out of date, there are very few decent alternatives left out there. Those apps of course tend to hit 100k so you or I can no longer use them. I lost my token for my preferred app when changed my Twitter @ name and went to re-register.

I’m only still using Twitter because I’ve found a backstop solution which … surprise surprise … the developers are no longer maintaining because of Twitter’s 100k policy. So sooner or later, this one will die as well when Twitter changes the API again.


#4

I got my account hacked today. No big deal other than some spam tweets to a Russian website and a password reset.

Or so I thought, because while I was able to reconnect my favourite Android client (twicca), my preferred desktop one (Janetter) didn’t work.

So that’s it, then? I’m screwed forever out of Janetter?


#5

Yup.
It gets better. For me at least, if I click in Janetter to register the app, when the Twitter page opens to tell me there are no tokens left, it logs my browser out of Twitter.

I guess it’s a deliberate move to stop people constantly retrying to gain rare tokens as other people unregister the app from their account. Seems a bit cynical to me.


#6

The same happened to me. I thought it was a cookie problem on my browser, but as you say it appears to be deliberate.

I tried contacting @Janetter_jp but they are barely active, and what little answers they’ve given on the subject are pretty much useless (they tell people to ‘sign in’ to get reauthenticated, but that doesn’t work)


#7

I had the same issue and i managed to solve it!!!
https://twitter.com/ryotay/status/423306672434470912 I’ve noticed that they retweeted this, no clue what the Japanese text means, but I removed “force login” from the url and it worked!