Exclude_replies/with_replies missing tweets

api

#1

In the last few days, API calls to user_timeline (with exclude_replies not set) started missing tweets.

We get the same result when viewing the timeline via twitter web.
For example:
https://twitter.com/tweepsmap shows our tweets on the 28th

But https://twitter.com/tweepsmap/with_replies only shows our replies on the 28th

Also, if you another user views the timeline they can see both, but if we view the timeline (logged in) the tweets are missing

Any ideas?
Thanks


#2

Just to be clear - these are API calls to api.twitter.com? You reference web URLs in your post.


#3

Hi Andy,
Yes, I was referring to Rest API, but also get the same result when accessed from web urls above.

Thanks,
Samir


#4

I’m sorry, I’m still confused about the behaviour you’re describing (my misunderstanding I think).

Are you able to share any example calls and (subset) results?

I’m unable to reproduce this using, for example:

twurl "/1.1/statuses/user_timeline.json?screen_name=tweepsmap&exclude_replies=false"

This shows me replies sent through that account as well as organic Tweets. Additionally, using the same on my own logged-in account, also includes replies as expected.


#5

Sorry Andy, I think it is a bit confusing
First I will share two screenshot, easier to understand


#6

Second, I am attaching the response for
twurl “/1.1/statuses/user_timeline.json?screen_name=tweepsmap&exclude_replies=false&count=50”

See response here. Note the missing tweets, as per the screenshots above
Thanks,
Samir