Exasperated trying to get Summary Card with Large Image to work - please help!


#1

I’ve been trying to use Summary Cards with Large Image for months now and trying to get them to work is a nightmare. Having tried using several Wordpress plugins to do this, including a premium one, with no success, I eventually managed to get them to work using Yoast.

But I can no longer get the Yoast method to work for these cards. I tried to tweet two of my blog posts yesterday, and when I entered their URLs in the Card Validator, both of them looked great, and were accompanied with images. However when I then tried to share them to Twitter, I just got 2-lines of text with no image or post exerpt.

I wondered if there was a caching problem, and decided to try again today. Now when I put the URLs in the Card Validator I’m getting: “INFO: Page fetched successfully. WARN: No metatags found.”

I do not have coding ability so I can’t insert metatags using coding, especially as I’m using the Enfold theme, which overrides standard Wordpress coding.

I have added metatags to all the required Yoast fields, including correctly-sized images. I have also inserted info in the Wordpress Excerpt field. I have gone through all the Yoast instructions to make Twitter cards available again, step by step - in any case, it worked before so I don’t think this is the problem.

I also have renditions from the JM Twittercards plugin visible on the Wordpress edit page, and it looks fine there, apart from picking up the wrong piece of text, probably due to Enfold’s Advanced Layout Builder. However I did manage to get Twittercards to work before, using the same theme and layout builder.

When I try to share to Facebook I get none of these problems - I get a nice big featured image and an excerpt.
But I want to share these posts on my Twitter account. I don’t have a Facebook page for my website.

Can anyone help?


#2

I’m very sorry that you are struggling with our Cards! :frowning:

The most important thing we need in order to help you is a link to the page you’re trying to share. Have you tried your link(s) in our validator?

We also have a lot of troubleshooting information available in our docs and here on the forums. We have our own official Wordpress plugin which is free to use, but I’ve also seen success with both Yoast and the JM plugins before. Be careful NOT to use multiple plugins at once as they will all add Cards data to the pages and confuse our system.

If you can share the link(s), someone may be able to help you.


#3

Thanks for your reply Andy.

The URLs I’m trying to tweet are:
http://www.freethinkinghealth.com/new-research/weight-loss-to-w…ould-be-your-gut/

I did try the Card Validator and initially both tweets looked great in the Validator, but then when I actually tried to tweet them, I just got 2 lines of text with no image or post excerpt.

I tried the URLs in the Validator again the following day, and this time I got the message: “INFO: Page fetched successfully. WARN: No metatags found.”

I will disable one of the plugins I’ve been using and see if that helps.


#4

I’ve disabled one of the plugins, and I’m now getting a successful result in the Card Validator for the second link, however the actual tweet is still just 2 lines of text with no image. And for the first link I’m still getting “No metatags found” in the Card Validator.

I’ll try the official Wordpress plugin now.

I’ve now tried the official Wordpress Twitter plugin and unfortunately it didn’t help.


#5

Do you have any of the plugins active at the moment? I’ll take a look at your links in a little while if so.


#6

Right now, for both links, I see a summary card validating correctly. However, it still looks like you have multiple plugins enabled, as when I search the HTML source for the pages I find twitter:card in two places. The first specifics summary large image, the second specifies summary, and the validator picks up the latter.


#7

Hi Andy

Sorry - I was away from my computer for a bit. But before I went I disabled all of the Twittercard plugins except for Yoast.

I’m still getting the “No metatags found” message from the Card Validator, and the tweet is still just two lines of text.

Actually for the second link the card does validate correctly, but the tweet is just two lines of text.


#8

Hey Natalie - I Tweeted the second link on my test account and it shows a summary card (click through the link to the Tweet to see it).
https://twitter.com/evilpiper/status/80621027315780812

I don’t know what is happening on your site, but when I “view source” on the page in my browser, and Ctrl-F search for twitter:card, I find it twice - once from Yoast with Summary Large Image, and again lower down with Summary. The second instance comes last, so that’s what our side is picking up and displaying.

Again I am sorry this is so frustrating for you - but hopefully that gives you something more to go on…


#9

Unfortunately I can’t get that link to work - I’ve tried it on a couple of different browsers. I really don’t understand why this won’t work now when it did work previously with Yoast.


#10

So are you saying that visiting the link I posted to a Tweet with a working card does not work? Or that posting the same link in a new Tweet yourself does not present the same card in the final posted Tweet?


#11

Visiting the link you posted to the tweet with a working card doesn’t work - I’m just getting a blue screen with the message: “Sorry, that page doesn’t exist!”


#12

My mistake - I cut a digit off the URL - try https://twitter.com/evilpiper/status/806210273157808129


#13

Thanks - that is the same result I’m getting in the Card Validator, but it’s not working when I try to send an actual Tweet. I’m still getting just 2 lines of text.

Also, it’s not exactly like the “Summary card with large image” that I really want to tweet, and which I did succeed in tweeting a couple of months ago.

I’ve even tried changing to a simpler Wordpress theme, but I’m getting the same result.

I’m using a sharing buttons plugin to tweet the post - could that be the reason why it’s not working? Is there a different way to tweet a blog post so that it comes out as a Twitter card with large image?


#14

You need to make sure that the URL is included in the Tweet itself for the card to be rendered in the Tweet.

The reason that this is showing as a regular summary card is that you still have two sets of cards markup in your pages - you need to find what is including a summary card instead of the summary large image card.


#15

I have tried just tweeting the URL as a direct tweet now, and it did work, though not with the large image (previously I was including the URL, but using the sharing buttons).

Maybe the sharing button plugin was the problem, though it did work a couple of months ago using the sharing buttons plugin.

I’ve tried disabling all the plugins and I got the same result, so I really don’t know why there are 2 sets of cards appearing. I’m glad that I’ve been able to get this result anyway, so I’ll do some more experimentation to see what works and what might be causing the problems.

Thanks for your help.


#16

Success! I’ve finally managed to get a large image summary card to work by deleting the sharing buttons and also deleting JM Twitter Cards, but keeping Yoast enabled.

I’ve also tried re-activating the sharing buttons plugin, and the card then reverted to the smaller image, so I think that’s where the problem lies.

I will now try restoring the original website theme to see if that makes a difference. I’ll also have to work out a way of including sharing buttons that don’t cause this problem to happen. But I’m very happy that I can now use these large image Twittercards to share my posts now.


#17

Finally I tried reactivating the original, more complex theme, and the large image did not work with this (although it did work before).

I was thinking about changing the theme anyway for other reasons, so i will go ahead with that now.


#18

Exactly the same issue here. Never have been able to get large summary to work. Gave up until today. Triple checked markup and OG and all is there. Been using Yoast and then tried JR as well. Preview showed correct but tweet was summary. Validator shows either summary, not white listed, timed out, or internal server error. Also tried refresh tweet old url more than 20 days old using bitly and that didn’t change anything.

Now get this! Last week after deleting Yoast while we were working on optimizing the website, one of my tweets was changed to an entirely different URL that went to the category page with that pages featured photo and not the post URL which was originally tweeted! Next tweet, the large summary appeared in timeline then disappeared back to summary the next day’s tweet of a new post.

So basically I think Twitter is blacklisting certain sites as mine is PG-13 for the most part and I take care to not Tweet R o r X images individually. Today, the featured images stopped appearing in the post page summary card so it’s only getting worse. So if your site has any of that kind of content maybe censoring is why you are having a problem. If anyone from Twitter would like to try it, here is a link to a PG-13 post. An explanation would be nice!

http://photostream.meinmypantyhose.com/amateur-pantyhose-mix-22/

I’ve run out of known troubleshooting steps other than to wait another week to see if the bot re-crawls the site and changes the card type. Good luck! Let me know if you make any progress on this!


#19

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.