{"errors":[{"message":"Could not authenticate you","code":32}]}


#1

HI

Any idea about the occurance of this error…?

I am sure there is no issue with my auth tokens…what else could be possible?

My authorization sig is like–

OAuth oauth_consumer_key=“KZUXQkvPvyEXgaQ", oauth_nonce=“3bc808b5a1daac2a00cd72ede9a4121f”, oauth_signature=“DXKIxgRB%2BQaeegxlHELYy3%2FIKZk%3D”, oauth_signature_method=“HMAC-SHA1”, oauth_timestamp=“1349711362”, oauth_token="633872218-MzdvstGsDX6wGTnsOH8i8SFvTm7E8ZaMG”, oauth_version=“1.0”

Thanks
Shakeb


#2

I am also getting the same issue. The access token is valid as I am able to access the other resources. Any help appreciated


#3

I have encountered the same issue with one of my app but not others. I resolved it by regenerating the access token and it now works again.


#4

I am also experiencing this problem. I’ve yet to find a solution…


#5

me too… any ideas?


#6

Same problem here…
i regenerated my access Token, included HTTP header, and still is not working.
For authenticating under my own signature and sending a simple /frinedship/show request I keep receiving the same error…


#7

There are lots of reasons you can get OAuth errors like these. I recommend reading [node:204] for some typical cases and common things to look at.


#8

Same issues… help please


#9

Same issues, it works 7/10.


#10

Check to see if you gave the app Write Permissions


#11

This error massage come when post the status when ever access token access token secret is working well to get the dtat from twitter
{“errors”:[{“message”:“Could not authenticate you”,“code”:32}]}
please help ASAP


#12

Hi, I am also getting same error, I am unable to understand how to resolve this.

Missing @ANYWHERE js :((


#13

I was getting the same error but for me it was a simple issue. I did not pay careful enough attention to the documentation. When building the “signature base string” the values must be in strict alphabetical order - so this includes the name/value pairs you are including in your query string (GETs) or post data (POSTs). I wasn’t doing this, so some of my API calls worked and some didn’t - purely by fluke (if I happened by chance it include them in the correct order).

When I ensured that they were in order then it all worked fine. I found it my just using the oauth tool for the API in question to generate the example signature, header and HTTP request, then comparing it to the versions my software was generating. It stood out like a sore thumb then.


#14

I had the same issue, after painstakingly resolving the same problem a couple of weeks ago and thinking I had the authentication header worked out I found it was failing on GET requests…my problem was I forgot about the “POST” prefix when building the authentication header and subsequently using that to generate my signature. Change the leading “POST&” to “GET&” for your get requests (as well as in your httprequest object). I wasn’t seeing it when comparing the results from the OAUTH tool because my eyes had been skipping right over it.


#15

Same problem: tokens already new generated, request in alphabetic order, app has write permissions, base string and signature tested at http://quonos.nl/oauthTester, seems to be OK.
Any ideas?


#16

Same issue here…


#17

got the same problem. any ideas?


#18

There are many possible reasons but I do not thing that it is coincidence the fact that we ALL are getting the same problem since the introduction of API v1.1.

Is someone working seriously to amend this? I would appreciate if Twitter seriously put hands on this as it is not an API issue, but a PAIn issue.

PS: I am still waiting for a solution to my problem (https://dev.twitter.com/discussions/18644) which is more or less the same…

Thanks


#19

Same Issue Here, I’ve reset app keys but Still same Issue. Any Clues…?


#20

okayi faced this problem this morning , but i was able to figure out immediately as it happened just after introducing a change in my url query formation

Earlier i was searching for say Movie The unstoppables
the moment i shift my query to Fast & Furious i started getting this error (& is the devil here)
so my conclusion is you get this when you have malformed query and any of these “&” out of place as they are actually parameter separators as per twitter url formation definition,Hope this helps