{"errors":[{"message":"Could not authenticate you","code":32}]} -- Same here, but not for newly created app. PLEASE HELP


Please assist me with this critical issue. I have hundreds of messages to deliver this weekend for several large Marathons and my application has stopped working entirely.

I am getting {“errors”:[{“message”:“Could not authenticate you”,“code”:32}]} consistently on every request to https://api.twitter.com/1/account/verify_credentials.json. The oath process seems to go just fine, but I cannot then use the API. I tired both 1.0 and 1.1.

My application is RTRT.me, in my console it is https://dev.twitter.com/apps/1537718

As a test, I created a new application, and use same code but with the new consumer/secret from the new app and it works perfectly. This leads me to believe there is something wrong with my app itself.

The test app (that works) is https://dev.twitter.com/apps/3739506

I tried reseting the Keys on my app and it did not help.

Please look into this…we cannot switch apps at this point, and apparently we will not be able to deliver messages unless this is corrected.




Are you sure that you’re using a valid access token? Are you able to generate new access tokens with the same application? It can be easy to accidentally invalidate your access token – the best way to rule that possibility out is by recreating it and using the new strings with your original application.


Yes, we regenerated valid tokens…that was not an issue.

Today, it has started working again. We changed nothing since yesterday. Clearly Twitter internal issue. Thanks


I’m also seeing this behavior intermittently.


I have a number of mobile apps and this is happening on all of my Android devices - yet the iOS versions are working. The error (Code 32) happens consistently on the android version, which is just using a pin based oauth flow. the tokens are generated but the verify_credentials API call is failing everytime.

This app has been working fine for over 1+ yrs until the last week - can someone from twitter please explain if something has changed and what it might be?


if we have following symbols in our Post request, it returns {“errors”:[{“message”:“Could not authenticate you”,“code”:32}]}.

  • !
  • (
  • )


This happened to me when I was accidentally using the oauth_token to both send and sign, when oauth_token_secret should be used for signing.


This was an intermittent issue for me too (could send a tweet via API 1, but not API 1.1 with the same credentials) and I have managed to reproduce this behavior. It looks like the problem is that the tweet I am trying to send contains the \302\240 character. I’ve added it to the discussion here:


Yep, same happens here.


I am using “http://twitter.com/oauth/request_token” url to get request token in my asp.net web application my keys are as follows

consumerKey = “XXXXX”;
consumerSecret = “XXXXXX”;

Earlier it was working fine but suddenly i am getting “The remote server returned an error: (401) Unauthorized.” error .

Please let me know if there is any changes u guys had made in API v1 becuase i am using v1.0


I too had this problem. Where my iOS version of the app worked fine but the Android one failed with a could not authenticate error. So after intercepting the calls with Burp it seemed that the query string was being un-encoded on the Android version. I was using the Appcelerator httpClient and there is an option to toggle setAutoEncodeUrl. Once set to false everything worked just fine. Maybe this option also exists in the native Android http client.


hii …please help .
how can i follow the user in my site … i am using twitteoauth…!! version 1.0 …in json…!!
friendship/create.json …its not working …how to follow people in my site pls tell me …!!




use this library


I have the same trouble,but now I found where I made a mistake.
At first,I invoke the sign request first then I add the query string

I coded like this:

twitterOAuth.service.signRequest(twitterOAuth.accessToken, request);
request.addQuerystringParameter(“screen_name”, “huanglipeng329”);

then I try to reverse the invoke order.
I coded like this:

request.addQuerystringParameter(“screen_name”, “huanglipeng329”);
twitterOAuth.service.signRequest(twitterOAuth.accessToken, request);

surprisingly,I found the problem solved!