{"errors":[{"message":"Bad Authentication data","code":215}]}


#1

Hi, I am Using Twitter Api in Various website and now I getting the Following error. and also I not have any twitter Application.
and now if I am using the new API v1.1 Apis for /get/statuses/user_timeline
getting the following error:

{“errors”:[{“message”:“Bad Authentication data”,“code”:215}]}

If Possible please provide a solution how i can achieve this without creating an Oatuh signature or App for it.


#2

i am facing same issue ,please can anybody help us, i am getting stuck


#3

There is the new library For Ruby. which support v1.1 Twitter Api. and working fine for me

Now we need access token to fetch tweets and search tweets from use timeline


#4

How can this issue be solved in Zend ?


#5

shift on API 1.1 :slight_smile:


#6

I can not understand, i have searched a lot but with no success.

What i have to do now?
Before that link worked http://api.twitter.com/1/statuses/user_timeline.json?screen_name=myname&include_rts=true&count=4

Now when i try to use http://api.twitter.com/1.1/statuses/user_timeline.json?screen_name=myname&include_rts=true&count=4
says bad authentication. What i have to do?


#7

Can anyone tell me whats wrong with this code?


#8

Same problem facing in Objective-c, can anybody help?


#9

{“errors”:[{“message”:“Bad Authentication data”,“code”:215}]}


#10

I’m experiencing the same issue… Anyone resolved this yet?


#11

i have a same problem !!!


#12

me either!
please help us!


#13

I’m having a similar problem, when I try to generate a cURL command through twitter’s oAuth tool I get the following code >

curl --get ‘https://api.twitter.com/1.1/statuses/home_timeline.json’ --header ‘Authorization: OAuth oauth_consumer_key=“SECRET”, oauth_nonce=“SECRET”, oauth_signature=“SECRET”, oauth_signature_method=“HMAC-SHA1”, oauth_timestamp=“1379366110”, oauth_token=“SECRET”, oauth_version=“1.0”’ --verbose

When I try to run the code in CMD I get >

    SSL certificate verify ok.

GET /1.1/statuses/home_timeline.json HTTP/1.1
User-Agent: curl/7.32.0
Host: api.twitter.com
Accept: /

HTTP/1.1 400 Bad Request
content-length: 61
content-type: application/json; charset=utf-8
date: Mon, 16 Sep 2013 21:17:17 UTC
Server tfe is not blacklisted
server: tfe
set-cookie: guest_id=v1%3A137936623778130572; Domain=.twitter.com; Path=/; Exp
res=Wed, 16-Sep-2015 21:17:17 UTC
strict-transport-security: max-age=631138519

{“errors”:[{“message”:“Bad Authentication data”,“code”:215}]}* Connection #0 to
host api.twitter.com left intact

ANY IDEA WHAT I’M DOING WRONG? THANKS!


#14

“errors”:[{“message”:“Bad Authentication data”,“code”:215- I am facing this issues while i am hitting

https://api.twitter.com/1.1/followers/list.json?screen_name=dillip321, Need some suggestion


#15

Hey , I am facing same problem, even i concate the valid user in the profiles… Have you got any answer


#16

any solution to above issue?? I am also striking my brain since one day…


#17

I’m facing same issue. Did you have any solution to resolve?


#18

I was also facing the same issue. My app redirect back successfully. But when I try to get the user property then it was showing the {“errors”:[{“message”:“Bad Authentication data”,“code”:215}]}.

Finally I got success to solve this issue. I have changed my OAuth library version variable value from 1.1 to 1.0.

Hope this information is working for you. All the best.


#19

I am encountering this also. Any advice please.


#20

Which OAuth library were you using when you solved this with the 1.1->1.0 change?