Error with Twitter.sharedInstance().startWithConsumerKey

ios
oauth
swift

#1

I’m getting the following error after I wiped out my existing twitter app and reinstalled twitter.

*** Terminating app due to uncaught exception ‘NSInternalInconsistencyException’, reason: ‘TwitterCore.framework version (1.14.0) doesn’t match TwitterKit.framework (1.13.1). Please, make sure both kits are up to date.’***
.
.
.
libc++abi.dylib: terminating with uncaught exception of type NSException
(lldb)

I check my keys are correct yet I’m getting this error. I’m not sure how I could maintain the version consistency.

Please help


#2

I managed to use cocoa pods and update which did solve the problem. But now I can’t load any tweets. This is the error I get:

[TwitterKit] Couldn't load tweets from TWTRTimelineViewController: Error Domain=TwitterAPIErrorDomain Code=200 "Request failed: forbidden (403)" UserInfo={NSErrorFailingURLKey=https://api.twitter.com/1.1/guest/activate.json, NSLocalizedDescription=Request failed: forbidden (403), NSLocalizedFailureReason=Twitter API error : Forbidden. (code 200)}


#3