Error when install Twitter-Ads

api-access

#1

I want try to get data from ads.twitter.com, there say we can use Twitter Ads API for do that,
and i try to install Twitter-Ads, and got this error:
“python setup.py egg_info” failed with error code 1"

anybody can help me to solve this problem? or have some recommend to use another API for ads.twitter.com ?


#2

What version of Python are you using? You can find out by doing python --version from the command line. From the Twitter Python Ads SDK README:

This project is designed to work with Python 2.7 or greater. While it may work on other version of Python, below are the platform and runtime versions we officially support and regularly test against.

Platform Versions
CPython 2.7, 3.2, 3.3, 3.4
PyPy 2.x, 4.x

Ensure you are using an officially supported version / platform.

For example, my Python version is 2.7.9 and doing pip install twitter-ads works just fine and as expected.

Additionally, this Stackoverflow answer might be helpful.


#3

actually my python version is 2.7.10
i guess its match with the requirement already and i also follow the stackoverflow, still no work.

btw, have any API can get data from ads.twitter.com?


#4

Have a look here for details on the Ads API, getting access and the different levels available.