Error The form has become outdated. Copy any unsaved work in the form below and then reload this page


I cant generate new apis keys or toke, and i cant delet any apps wuts happen?
Is anything wrong at twitter? Please help would be appreciated.


I am getting the same error message every time I try to create an app. Please help! Thanks


Is this error message coming from the web page itself, or from your browser? Can you take me through the exact steps you’re performing to reach this error?

I just created an app, generated keys, then deleted it—didn’t see any errors.


Thanks for your assistance Issach! The error message is on the web page itself when using Safari. I filled in the four windows with the correct information: SocialFans Counter (the app), "counting my followers, and then my web site address in the last two windows. Then I click the “Yes, I agree” box and then the “Create your Twitter app” button. That is when I get the error message in a red-shade box at the top of the web page.

When I try to create my Twitter app on Chrome and Firefox, I get this error message:

Error Validation failed: SocialFans Counter is already taken for Name

Thanks again!


Very strange, I’ll look into the problem with Safari. Does sound like there’s already an app registered with the name you want, though—does it work if you choose a different name?


I tried it with a space between “Social” and “Fans” and it still did not work.


Finally got it to work by using Safari on my iPhone. Definitely some type of browser issues. Thanks!


I’m also getting the same error message. Is there a work around?


I’m also getting this error. I’m using Chrome 38.0.2125.104 on OS X 10.9.4.

I can’t make any changes to App’s setting page.


I just tried to create a new app all together, and ran into this. Id there a work around so I can create the new app?


It seems to work with FireFox on OS X (Mavericks). I can modify my app settings now. Disappointing to move away from Chrome.


Same error here, “The form has become outdated. Copy any unsaved work in the form below and then reload this page.” Safari, Chrome, and Firefox on Yosemite.


I have still the problem. I want to change an site, add new one all the time I get error, Drives me crazy!!!

Error The form has become outdated.


I still facing same problem. and not able to create new application. please solve this issue asap.
and images also not loading on twitter.

The form has become outdated. Copy any unsaved work in the form below and then reload this page.


M also getting the same error


We deployed a fix for this issue yesterday. Are you still experiencing it consistently?


I get the same error when I creat my access token today. can you give me some help? thanks!


I just tried the same thing. Last version of FF and tried different name and everything but still same issue.


tried with IE 10, Latest versions of Chrome and Firefox. Not working on any of them. And the site itself looks so lame and broken on all these browsers - just text, no formatting anywhere.

Unbelievable that a site with so much traffic can have such an issue open for such a long time.


This is odd - we obviously do test in Firefox and Chrome and I don’t see issues here. I’ve also just tried in IE 10 on Windows 8 in a virtual machine and the formatting looks OK. I wonder whether the CSS is being loaded correctly on your machine? Are you able to try from a different network connection?