Error reason: User profile request failed! Twitter returned an error. 401 Unauthorized


#1

Using http://wordpress.org/plugins/socialauth-wp/ WP plugin on my site.
Created the App and filled in all the required fields.
Then copied my Consumer key and Consumer secret into the SocialAuth-WordPress Settings fields for twitter.

Redirect URI: http://hdtattoogirls.com/wp-content/plugins/socialauth-wp/hybridauth/?hauth.done=Twitter
API Key:
App Secret:

But twitter login is failing on my site with “Error reason: User profile request failed! Twitter returned an error. 401 Unauthorized.”

Why do I have a

Consumer key: *
Consumer secret: *
Access token: *
Access token secret: *

Which one do I put? I have tried both but same thing happens.

For Request settings
Request type: *
Do I put GET or POST?

For Callback URL:
Do I put the URL of my site or some other type of URL?

Thanks for your help guys.


#2

Had the same problem because i left the call back URL field blank. Try putting the URL of your site.