Error processing your OAuth request: Read-only application cannot POST


#1

Hi, when I try to send a direct message using a .Net library called Twitterizer2, the request throws an error :

“Error processing your OAuth request: Read-only application cannot POST”

I have reviewed the tokens and consumer keys, I changed the application access level to “Read, Write and Acces direct messages” level. Then I have reset my keys and I have regenerated it using oauth tools.

After two hours I am continuing having the same error.

What I have to do?
Thanks.


#2

Solved:
I had not reset OAuth keys


#3

I had the same problem. Thanks to your comment I fixed it quickly.
Change the app permission to write and reset all the tokens and keys :).


#4

I am having the same problem. I’ve tried everything but nothing seems to work. Does anyone have any other suggestions? I would love to get this up and running quickly.
Thanks!


#5

To solve this error make sure you do the following:

  1. You have confirmed your email with twitter
  2. You set you application settings to Read/Write
  3. You reset your keys/token
  4. WAIT - Took twitter a little bit to reflect the changes I made to my app, once it updated though it fixed the error (so give twitter an hour or so to update).

#6

Thank you Hustin finally i got solution


#7

Good!