Error on card preview: Fetching the page failed because connection is refused


#1

I’m not able to preview any type of card I’ve tried (summary, summary with large photo, photo).

I’ve attempted validation with the following URLs:


https://www.eng.ufl.edu/research/experts/

robots.txt: https://www.eng.ufl.edu/robots.txt


#2

I am also having the same problem even using the test code.

https://www.makusi.tv/twittercard/player/page.html


#3

OK I fixed my problem. I had not paid attention to the data that came in the bundled download for testing the twitter card, where it says this @rchoi must be replaced with the sites or user´s username. Now I managed to validate and I must wait for approval :smile:


#4

Having the same issue for the past 6 days - cannot validate any cards - connection refused!


#5

Cards are working for me if i do not use a SSL connection:

https://omgtap.co/b/?6rnefQA - does not work (connection refused)
http://omgtap.co/b/?6rnefQA - works just fine.

Anyone have a workaround for SSL card links?

Thanks!


#6

Same thing happening to me


#7

https://omgtap.co/userfiles/10000/10001/blogs/1425642240_Killing_Time/ (SSL not working)

http://omgtap.co/userfiles/10000/10001/blogs/1425642240_Killing_Time/ (Non-SSL working)

More info in case someone out in Twitter land is paying attention…

Thanks!
Greg


#8

We have same error in our website after using https on all pages. Our SSL set up correctly and all page shows green. It validated through all social media except twitter that shows
ERROR: Fetching the page failed because connection is refused.

We checked SNI (server name identification), we checked port 443 also we contact with symantec support regarding any SSL issue.

I am guessing this is Twitter Java Oracle issue, and it needs to solve by twitter team by upgrading their Java. Hopefully someone from twitter team respond us ASAP.

https://viebelles.com/us/blog/smash-of-the-titans/


#9

ufl - that looks like a firewall problem.

For everyone else:

Your SSL certificate must match your ServerName or ServerAlias. For omgtap.co for example, your certificate is issued to “www.omgtap.co” and for www.talenteca.com your certificate is issued to “*.talenteca,com” - neither of these are exact matched for the domain, and Twitter seems to choke on it.

If you have apache, go to your ssl.conf for you domain. You will probably see:

ServerName www.omgtap.co
Change it to

ServerName omgtap.co
ServerAlias www.omgtap.co

For talenteca, you would change is to

ServerName www.talenteca.com
ServerAlias*.talenteca.com

Restart apache and have a nice day. If you are on a different server, make the equivalent changes.


Card validation ERROR: Fetching the page failed because SSL handshake error
#10

As engineering continues to investigate on our side, I’ve been asked to inquire about the hosting service providers used by those affected. Could you please respond here with that information? If you’ve already responded on another related thread, you do not need to respond here as well.


#11

Hi jbulava:

Thank you for follow up, as I mentioned earlier we thought this is twitter server java bug and will be solve by upgrading your server java version. Maybe for some company or users this issue comes from their server name but not for all people.

Regards,


#12

I just remind one more thing, for a first time that we noticed this issue, we thought may be twitter upgrade its server to follow up google announcement in SHA2 SSL, then we upgrade our SSL too. The result was same. This is for those who tought maybe by upgrading SSL security for SHA2, this problem will be solve. I think they are wrong.


#13

We are using Godaddy Dedicated server.


#14

We also have the same problem on our site with URLs like:
https://www.sydneytheatre.com.au/whats-on/productions/2015/endgame

We are running on AWS using Apache behind ELB.


#15

Having the same problem, also on a server that uses TLS. I was just redoing some OG/Twitter metadata on my site and I tried tweeting one of my pages to test. No card shows up in the resulting post. You can see the page here: https://fedgeno.com/apps/global-paradigm-shift/links/crooked-i-life-after-death-row-dvd-full-dvd-2835230

You can see the resulting tweet here: https://twitter.com/OccupyNA/status/585295629854715904

What’s strange to me is that I’m using Twitterfeed to auto-post at regular intervals and some of those posts are showing proper cards.

If you look at my profile, all of the tweets with bit.ly in the link are auto-post via Twitterfeed. Some seem to work while others don’t. There’s only two sets of code being presented by that part of the site. One is presented for regular links and another is presented for pages with YouTube embeds. The hit and miss aspect of this doesn’t seem to correspond to that.

https://twitter.com/OccupyNA


#16

Even when my player cards were working, they never worked when posted thru an API from my site (I also used a ‘scheduled’ posting utility that i created). I just assumed that the player cards did not work unless the poster was actually online at the time.

Greg


#17

We’re facing the same issue - we are hosted at Vidahost.com - Site URL https://450gsm.com


#18

They generally do work when posted via Twitterfeed. I’m having the same issue with manual posting. It’s not a problem with the API. The cards are scraped independently, directly from the page in question.


#19

Maybe some apps don’t get permission to run the scraper on their links but Twitterfeed definitely does. I’m pretty sure IFTTT works as well. FB’s fb.me link shortner/post to Twitter API thinger also does work with cards.


#20

As mentioned in the thread linked below, there was a fix pushed to production last month. This should solve the “connection is refused” issue. If you have any further issues or questions about the validator, please feel free to open a new thread.

To answer any ambiguity about when Cards are attached to Tweets, the source of the Tweet does not matter. Every Tweet we receive (via our mobile app, Twitter.com, API, TweetDeck, etc) is checked for URLs and all new URLs are checked for Twitter Card meta tags. Currently, the cache for a Card on our side is 7 days, so we will reach back out to URLs we’ve already seen after that amount of time to refresh.