ERROR: No card found (Card error)


#31

Hi Andy

I have the same problem

Here
http://www.keubble.com/chismeando/view/videos/4984/accidente-aéreo-en-taiwan/
INFO: Page fetched successfully
INFO: 2 metatags were found
ERROR: No card found (Card error)


#32

me too
I ve put the twitter cards but it doesn’t works

INFO: Page fetched successfully
INFO: 2 metatags were found
ERROR: No card found (Card error)

Check here

Bourse
Calculatrice
finances personnelles
Calcul hypothéque
dollar canadien


#33

As the validator tells you, your site is missing content for mandatory tags (twitter:description and twitter:title)


#34

Hello,
I’m having the same problem for http://ianbillen.com

My tags are:

	<meta name="twitter:site" content="@ianbillen" />
		<meta name="twitter:creator" content="@ianbillen" />
				<meta property="og:title" content="Ian Billen - It's quality...never quantity." />
					<meta property="og:description" content="Audio recording tips and insight, record reviews, and more." />
						<meta property="og:image" content="http://ianbillen.com/images/ian-billen-red-glasses.jpg" />

My robots.txt has

User-agent: Twitterbot
Disallow:

User-agent: *
Disallow: /

could it be because I am submitting under a different username? (I’m doing this for my client)


#35

There’s no twitter:card tag shown in your markup there.


#36

Many thanks :slight_smile: That worked.


#37

Having no joy validating any cards from funderama.com; always get the same response:

ERROR: FetchError:exceeded 4.seconds to Constructor while waiting for a response for the request, including retries (if applicable) (Card error)

Have run through documentation and troubleshooting without a fix. Could you take a look at

http://funderama.com/fund/fund-101-enterprise-nation/

Thanks in advance


#38

Unfortunately your site is not responding quickly enough when the validator tries to pull a page. You should take a look at improving performance.


#39

Thanks for the swift response Andy. I’m using a wordpress plugin to help organise/optimise social sharing (WPSSO) and had asked the developer to take a look, his response is below (< and > removed). Possibly not a speed issue?

Mike,

I can crawl that page in 0.760 secs, so there must be something wrong in Twitter’s end.

$ time wget -q -O - http://funderama.com/fund/fund-101-enterprise-nation/|grep twitter:
meta name="twitter:domain" content="funderama.com" /
meta name="twitter:site" content="@thefunderama" /
meta name="twitter:title" content="Fund 101 by Enterprise Nation | funderama.com" /
meta name="twitter:description" content="The Fund 101 fund available from Enterprise Nation offers an online competition for UK startup and small businesses to win &pound;500 to help fund a business project or proposition. Still Interested?..." /
meta name="twitter:creator" content="@thefunderama" /
meta name="twitter:card" content="summary_large_image" /
meta name="twitter:image" content="http://funderama.com/wp-content/uploads/2015/01/happykids-compressor-300x300.jpg" /

real 0m0.760s
user 0m0.003s
sys 0m0.004s


#40

I just checked your site, and I don’t know why but I am getting very mixed responses, for reference here are some extremes:

    time_namelookup:  0,004
       time_connect:  0,169
    time_appconnect:  0,000
   time_pretransfer:  0,169
      time_redirect:  0,000
 time_starttransfer:  0,342
                    ----------
         time_total:  0,707

    time_namelookup:  0,004
       time_connect:  2,187
    time_appconnect:  0,000
   time_pretransfer:  2,187
      time_redirect:  0,000
 time_starttransfer:  3,652
                    ----------
         time_total:  4,052

    time_namelookup:  0,005
       time_connect:  0,185
    time_appconnect:  0,000
   time_pretransfer:  0,185
      time_redirect:  0,000
 time_starttransfer:  9,792
                    ----------
         time_total:  10,304

The most important one there is the time_starttransfer, as it indicates the time until the first byte arrives.


#41

Same problem. Our website domain http://www.elimiapp.com was whitelisted some time ago and Twitter Cards worked just fine. Recently we’ve updated only the title & description in the tags and the result is “ERROR: No card found (Card error)” while trying to validate.

HTML code for the card:

<!-- Twitter Card data: App card -->
		<meta name="twitter:card" content="app" />
		<meta name="twitter:title" content="Elimi - looks & BRAIN matters!" />
		<meta name="twitter:description" content="Elimi is a game where looks & BRAIN matters! CREATE a simple profile & your games. BROWSE people & games near you. PLAY with selected people. CONNECT and chat only with the best ones!" />
		<meta name="twitter:app:name:iphone" content="Elimi - looks & BRAIN matters!" />
		<meta name="twitter:app:id:iphone" content="875294215" />
		<!-- app deep linking <meta name="twitter:app:url:iphone" content="example://action/5149e249222f9e600a7540ef"> -->
		<meta name="twitter:app:name:ipad" content="Elimi - looks & BRAIN matters!" />
		<meta name="twitter:app:id:ipad" content="875294215" />
		<!-- app deep linking <meta name="twitter:app:url:ipad" content="example://action/5149e249222f9e600a7540ef"> -->
		<meta name="twitter:app:name:googleplay" content="Elimi - looks & BRAIN matters!" />
		<meta name="twitter:app:id:googleplay" content="com.elimiapp.app" />
		<!-- app deep linking <meta name="twitter:app:url:googleplay" content="http://example.com/action/5149e249222f9e600a7540ef"> -->

#42

Your app card is working fine for me, although I’d suggest adding a robots.txt file to your site (optional, not required).


#43

Hello,

I try but I cant do this with blogger for my domain …http://goo.gl/QaAjkA

Meta Tags:

<!-- twitter card details -->
<meta content='summary' name='twitter:card'/>
<meta content='@MemoriasMundo' name='twitter:site'/>
<meta expr:content='data:blog.url' name='twitter:url'/>
<meta expr:content='data:blog.pageName' name='twitter:title'/>
<meta expr:content='data:blog.metaDescription' name='twitter:description'/>
<meta expr:content='data:blog.postImageThumbnailUrl' name='twitter:image'/>
<!-- end twitter card details -->

And when I check in a post (not domain) … “Unable to render Card preview”

And also this:
INFO: Page fetched successfully
INFO: 4 metatags were found
ERROR: No card found (Card error)

I try a lot… tested with others tags for the post in blogger but I can’t do it !!!
Please can you tell me where is the mistake ?

Thanks a lot in advance .-


#44

You page does not contain any of the needed meta tags in it’s <head> section.


#45

Hello,
i’m trying to include twitter cards into a dynamicly website-project, but twitter cards doesn’t work…

The card validator is showing differents results (Error, Unable to render Card preview…)
somtimes shows green logs, other times nothing

My Test-URL: https://immo-reinert.de/Grundst%C3%BCck-in-B%C3%B6tzow-(Velten)-bei-Berlin-kaufen/

<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@ImmoReinert" />
<meta name="twitter:title" content="Grundstück in Bötzow (Velten) bei Berlin kaufen, Bauland im Berliner Umland" />
        <meta name="twitter:description" content="%23ImmoReinert_Grundst%C3%BCck%0A%0A2622m%C2%B2+%23Bauland+%28%23Immobilien%29+im+Berliner+Umland%0A%23Grundst%C3%BCck+in+%23B%C3%B6tzow+%28Velten%29+bei+%23Berlin%0Ahttp%3A%2F%2Fgoo.gl%2F78c78o" />
        <meta name="twitter:image" content="https://immo-reinert.de/image/og/image1.jpg" />
        <meta name="twitter:url" content="https://immo-reinert.de/Grundst%C3%BCck-in-B%C3%B6tzow-(Velten)-bei-Berlin-kaufen/" /> 

Question:

  1. Why doesn’t work?
  2. I have to repeat the Validation for each Page?

Sorry for my english, and thanks for any help


#46

You have no meta tags in your post pages for some reason. You do have meta tags on the top-level domain, but some of them (title and image) are empty.


#47

I’m not sure why this is not working, but it could be bad handling on our side of the umlauted characters in your description. One thing I did notice, though, is that your robots.txt file is broken and returns a PHP error - you might want to take a look at that.

You should not need to validate every page, once a card type is working on your site that should be fine. The only exception is player cards, which require us to test and whitelist domains manually.


#50

Hi, I have a similar problem with my blogger blog.

I have used the below code but I continue getting this error: INFO: Page fetched successfully
INFO: 11 metatags were found
ERROR: No card found (Card error)

My blog address is www.the-liver-bird.co.uk

Can anybody please help?


#51

Check the troubleshooting post. I just fetched your page and there is no card markup on the page.


#52