ERROR: No card found (Card error)


#1

Hi,

Looking for some help. I’ve recently moved over to the Wordpress Genesis Theme and I’ve been looking at revamping how my site works. Everything has been stripped back to the barebones and I’ve started to rebuild. Today I came across the twitter Card which seems to be a great tool to have but I cant get it to validate. I’m doing it through Yoast and it is setup correctly but I’m getting this error message:

site is http://crystalstinytreasures.com

INFO: Page fetched successfully
INFO: 13 metatags were found
ERROR: No card found (Card error)

Any help or advise would be great as I’m stuck?

Thanks

Crystal


#2

Hi Crystal, thanks for the question! I think what is happening here is that the Yoast plugin is annotating the individual post pages with a card, but not the top-level homepage.

I just submitted this post to the validator:

and it shows a card preview and the ability to apply for whitelisting. Give that a try!


#3

Thanks Andy, that worked, just sent for Approval.

Thank you.

Crystal


#4

Hello Andy,
I am having a similar issue except my error comes from a blogger.com website (www.brand-lounge.nrdigitalbranding.com). I have setup the Twitter Card information a while ago and it worked fine, however it just disappeared recently - I get the same error as Crystal:

INFO: Page fetched successfully
INFO: 5 metatags were found
ERROR: No card found (Card error)

This is the code I have in my Blogger template (right before the tag):

<b:if cond='data:blog.pageType == &quot;item&quot;'>
    <b:if cond='data:blog.postImageThumbnailUrl'>
      <b:if cond='data:blog.metaDescription'>
        <meta content='summary' name='twitter:card'/>
        <meta content='@nemki' name='twitter:site'/>
        <meta content='@nemki' name='twitter:creator'/>
        <meta expr:content='data:blog.pageName' name='twitter:title'/>
        <meta expr:content='data:blog.metaDescription' name='twitter:description'/>
        <meta expr:content='data:blog.postImageThumbnailUrl' name='twitter:image:src'/>
        <meta expr:content='data:blog.homepageUrl' name='twitter:domain'/>
      </b:if>
    </b:if>
</b:if>
  </head>

Could you please let me know why this happens all of a sudden when it used to work before, and how it can be fixed?

Thanks,
Nem


#6

This is essentially the same problem as in this other Blogger-related post.

You have 3 conditional Blogger tags so the whole card will ONLY be shown IF you are on an “item” page AND you have a post image thumbnail AND you have a metaDescription set.

Therefore, cards will not work for http://www.brand-lounge.nrdigitalbranding.com/ which is the top-level site and only has a few cards tags rendered; but they will work just fine for an individual post such as http://www.brand-lounge.nrdigitalbranding.com/2014/10/happy-small-business-month-canada.html which has all the tags rendered.


#7

Hey Andy, I am trying to implement twitter cards to my site but when I run my URL in the validator I experience the same error:
Log
INFO: Page fetched successfully
INFO: 5 metatags were found
ERROR: No card found (Card error)

My domain is http://maramoja.co.ke ,please help me in making this work…don’t know where the error is coming from I followed the docs exactly


#8

When I try to get your page using curl -A Twitterbot http://maramoja.co.ke/index.php I get no output. It loads in the browser, but the root url (no index.php) has no cards markup; when I do reach index.php via the Get Started link, I see the markup.

You’ll need to fix this so that the Twitterbot (our cards crawler) always gets to see valid meta tags in a page that it is able to fetch, before you can run this through the validator.


#9

Hey Andy,

Does this mean having to add a robots.txt with the contents
User-agent: Twitterbot
Disallow:

User-agent: *
Disallow: /

and place it in the root of my server to allow the crawler access?


#10

That may help - I do not know why I cannot fetch a rendered version of your index page from the command line at the moment. If you have any redirects or other site-specific configuration there you should ensure that they resolve from a tool like curl.


#11

Hi, I have the same problem for my Wordpress site : http://www.code-reduction-rueducommerce.com . I have tried two plug-ins but :

INFO: Page fetched successfully
INFO: 14 metatags were found
ERROR: No card found (Card error)

I have tried many things without success.

Can you give me an advice ?

Regards.

IM


#12

Hi Andy,

I got the same problem.

Validation on my food blog: https://www.nudelheissundhos.de doesn’t work there is the same error message “no card found”.
Validation on a recipe page: https://www.nudelheissundhos.de/2014/11/15/versunkener-apfelkuchen/ works and I get the following message:
INFO: Page fetched successfully
INFO: 21 metatags were found
INFO: twitter:card = summary_large_image tag found
WARN: Not whitelisted
But the request is rejected, the URL did not validate because the page contains no valid metadata.

Validation for my book shop: http://www.buch-schmie.de is the same, only the URL with a post: http://buch-schmie.de/2014/11/06/betrachtungen-zur-psyche-in-zweiter-auflage-erschienen/ is validated and approved, the Twitter card was activated.

But both websites have the same configuration with WordPress and on both sites the same plugin Yoast SEO is installed. Why was the request for the food blog rejected?

Regards

Thobie


#13

Hi Andy,

issue solved. “Your Twitter card is ready!”

Regards

Thobie


#14

Hi. Having the same issue. My domain - www.the-newsroom.com - was whitelisted for Twitter cards early in 2014, but I noticed they’ve stopped appearing. I’ve tried adding the code again, but keep getting this message:

INFO: Page fetched successfully
INFO: 4 metatags were found
ERROR: No card found (Card error)

I have this code just above the tag in my template. Would appreciate assistance in terms of what I’m doing incorrectly.

> <b:if cond='data:blog.pageType == &quot;item&quot;'>
>    <b:if cond='data:blog.metaDescription'>
> <meta content='summary_large_image' name='twitter:card'/>
>       <meta content='summary_large_image' name='twitter:card'/>
>       <meta content='@MikeJenkinson' name='twitter:site'/>

>       <meta expr:content='data:blog.pageName' name='twitter:title'/>
>       <meta expr:content='data:blog.metaDescription' name='twitter:description'/>
>       <b:if cond='data:blog.postImageThumbnailUrl'>
>          <meta expr:content='data:blog.postImageThumbnailUrl' name='twitter:image:src'/>
>       </b:if>
>    </b:if>
> </b:if>

#15

Hi Mike - that code in your template will only be triggered for a blog entry page (blog.pageType = “item”), not for the root domain. I’ve just tried validating a card for a blog entry from your site, and it works fine. There’s no card for the main domain.


#16

Im also having a problem.

INFO: Page fetched successfully
INFO: 3 metatags were found
ERROR: No card found (Card error)

Im new to this so any help would be amazing.

URL: http://chriswardphotography.com/


#17

I cannot find any cards markup on your page, Chris, so the cards validator is correct to report “No card found”.


#18

Any pointers on what I need to do. I have a WordPress site and using Yoast SEO.


#19

You’ll need to configure the Yoast plugin to include Cards markup, and then also validate one of your posts or pages, rather than the root site domain. I’m not an expert in how the Yoast plugin works though so you’ll need to talk to the developers to understand what specifics are required.


#20

Ok thanks.


#23

I cannot find any twitter:card tags/markup in your page. Can you please show me the code you are using?