Error In IE8,10 SCRIPT1010:Expected identifier widgets.js


#1

Hi,

I have using the website Timeline widget it is working fine in Mozilla and Chrome but in IE8,9,10 it give an below error

SCRIPT1010:Expected identifier widgets.js

Here is my code

Tweets by @displaysigns

And website link is

http://www.displaysigns.net/

Please check it in IE

Please help me ASAP.

Thanks


#2

We removed support for IE7 and IE8 (and IE8 document mode) recently. So you won’t get anything working in IE8 I’m afraid.

Your page includes the line

<meta http-equiv="X-UA-Compatible" content="IE=8" />

What this is doing is forcing the browser into IE 8 mode. Try removing this. If you are seeing other problems, it is probably because some of the Javascript on your page conflicts with our widgets. You’re using a very old version of prototype.js which is no longer supported, for example.


#3

Hi Andypiper

I have removed this meta tag

and also upload the latest version prototype.js but still give an error in IE browser

Thanks
NIlesh


#4

This site appears to be working fine with a timeline widget showing in IE10 on Windows 8.


#5

I’m gettting the same javascript error with IE9, IE10, IE11 with Windows 7. The timeline had displayed without issues, but recently stopped working with IE. I put the widget code in a simple html page without the meta tag mentioned previously and it will not display. It works with chrome and firefox, but our company standard web browser is IE. Your help is appreciated.


Sharepoint 2010 & Twitter Widget
#6

Are you seeing a SCRIPT1010 error or just experiencing general issues in Internet Explorer? Are you running any ad blockers in Internet Explorer that might prevent platform.twitter.com from loading widgets.js?


#7

Hello I have the same error for ie9

If you insert

<!DOCTYPE html>

to your web-page, twitter widget is shown however our company site is not built for html 5, so it is not shown well in html 5.

Is there a way to show twitter widget in ie9 without inserting html 5 to web page?

I would be really happy if I can get a quick response.


#8

As we announced in November, we are moving towards modern web standards support by dropping IE7 and IE8, and this means that modern document modes will work better with the embedded widgets. I’m not aware of a quick fix for the issue you’re describing today.


#9

A page without a document may be rendered in Quirks mode by Microsoft. Microsoft recommends using the HTML5 document type to enable standards support document modes.
https://msdn.microsoft.com/en-us/library/ie/gg699338.aspx

You should choose a document type for the benefit of Internet Explorer. If you do not like the HTML5 document type there are other document types that may trigger standards document modes in Internet Explorer 9+. A table showing document mode treatments for Internet Explorer 9 across various declared document types.
https://hsivonen.fi/doctype/#handling


#10