ERROR: Fetching the page failed because the fetcher cannot resolve the address


#1

For two days now I have been getting ERROR: Fetching the page failed because the fetcher cannot resolve the address. on ever single page of my website.

It was working fine before and than it just stopped working.

Example url:


#2

Yes, we are actively investigating these multiple reports of timeouts and name resolution failures. Bear with us while we dig into this.


#3

Hi,

We are experiencing the same issue with our website. It works if we use the IP address but not the domain. We can’t determine any DNS issues at this time. Is there any update on this?

Thanks!


#4

Still looking into some timeout issues on our side - bear with us!


#5

I also have trouble validating the URL: http://www.interdixit.com/esp/noticia.php?pag=simplificacion_actualizacion_tecnologica_interdixitcom_buscando_sostenibilidad

05/SEP/15: Solved!!! Thanks


#6

Hi, just checking in to see if there were any updates on this?


#7

I’m also, just recently dealing with this issue. Are there is any updates, or things we should be aware of in order to deal with this issue?


#8

I experience the same problem, is there any updates?


#9

I also have this issue and have for quite some time.


#10

I Give Up

Here are more details on the issue I experience. I try to use a Summary Card with Large Image @projecklist

The validator failed to validate all the links I tested below. On the other hand, when I tweet, the card is working only with a specific url and it and MUST include ‘http://’ and ‘www’ and WITHOUT any trailing slash or other characters. For some reason it does’t work if the url is not explicitely written as follow: http://www.projecklist.oneprojct.space (no bit.y’s or any other variations)

Another issue I think is related is that the site support IL18N with 2 locales so far and the content of the meta tags used for the Twitter Card is dynamically generated to match the language of the user. I don’t understand why both http://www.projecklist.oneprojct.space/?Lang=en_CA and http://www.projecklist.oneprojct.space/?Lang=fr_CA are not working in both in the card validator or when I tweet these urls. I assumed they should both direct the bots to the french/english content and meta tags. I have tested this with open graph tags and its working fine. I do not understand enough to figure out why twitter cards behave differently.

There is no url format guidelines in your docs beside when you want to refresh the Card cache. Unfortunately, bit.ly’s don’t seem to work at all for me.

Validator Logs

- http://www.projecklist.oneprojct.space
- http://www.projecklist.oneprojct.space/
- http://www.projecklist.oneprojct.space/?lang=fr_CA
- http://www.projecklist.oneprojct.space/?lang=en_CA
ERROR: Fetching the page failed because the fetcher cannot resolve the address.

- http://bit.ly/1VaUr0S or any other bit.ly urls tested has the WARN: log redirected to their full urls.
ERROR: Fetching the page failed because the fetcher cannot resolve the address.
WARN:  this card is redirected to http://www.projecklist.oneprojct.space/

Robot.txt -> dev environment:

I have tested also with Allow: and Disallow: for all user agents * and did not fix the issue. Here the current setup I have as recommended in your docs:

# robotstxt.org/

User-agent: Twitterbot
Disallow:

User-agent: *
Disallow: /

.htaccess

Here are the only mentions of deny xxxx in my current .htaccess file and should not cause trouble, I think:

<FilesMatch "(^#.*#|\.(bak|conf|dist|fla|in[ci]|log|psd|sh|sql|sw[op])|~)$">

    # Apache < 2.3
    <IfModule !mod_authz_core.c>
        Order allow,deny
        Deny from all
        Satisfy All
    </IfModule>

    # Apache ≥ 2.3
    <IfModule mod_authz_core.c>
        Require all denied
    </IfModule>

</FilesMatch>

In case it makes a difference, I am forcing the ‘www’ in the url with this command in .htaccess

<IfModule mod_rewrite.c>

    RewriteEngine on
    RewriteCond %{HTTP_HOST} ^projecklist.oneprojct.space$
    RewriteRule ^/?$ "http\:\/\/www\.projecklist\.oneprojct\.space\/" [R=301,L]

</IfModule>

IL18N Troubleshoot Attempt

In order to get one Twitter Card image per locale, I have created an alternate index file with the required meta tags at http://www.projecklist.oneprojct.space/img/og/twcard-fr/ but both the validator and the tweets failed. (I want to do this because there some text that needs translation on the image itself)

Conclusion

Until this is resolve, I give up on twitter cards. I hope this content helps you to help me fixing this gap I experience.


#11

seems to be related to our ongoing issues resolving a small group of specific addresses, and your domain falls into that group. Apologies, and we are investigating.


#12

I have the same problem over and over again for 2 weeks now. My website is still on the testing server because I can not resolve the issue.
This is my url with the summary card that I can not validate.
http://teamup.emitknowledge.com:9916/job/521/Razvoen-proektant-vo-NLB-Tutunska-banka

pls help


#13

Unfortunately this is not something you’ll be able to resolve on your side, we are still working on infrastructure that deals with some URL resolutions. Apologies that this affects your site.


#14

Hi, I just wanted to check if there were any further developments on this. We are still getting Unable to render Card preview - ERROR: Failed to fetch page due to: R7.


#15

Hey Andy. wondering if you have any update response for “ERROR: Fetching the page failed because the fetcher cannot resolve the address”. My account experience the same issue. I am in charge of our app operating. I’m kinda in a hurry to waiting for this issue to be resolved. and here’s our domain :http://192.168.3.222:8095/wifitoolbox.html


#16

We have the same problem also,

ERROR: Fetching the page failed because the fetcher cannot resolve the address.

This should be solved the soonest.


#17

You need a DNS address, not an IP address.


#18

What address is failing?


#19

www.bankbusinesspromoters.com


#20

My machine is unable to resolve that domain, and nslookup also fails.