ERROR: Failed to fetch page due to: HttpConnectionTimeout

cards

#1

Hello guys!

I have problems with publishing link on twitter.

First my problem related to twitter validator. Early, then I post my link (https://stage-journals.lww.com/aenjournal/Abstract/2016/07000/Treating_Adult_Asthma_Exacerbations_With_a_2_Day.2.aspx) on validator, it correct displayed preview link, but at the moment it displaying this: ERROR: Failed to fetch page due to: HttpConnectionTimeout. I hope that after a while the problem will disappear (judging by the questions that have already been asked on this forum).

Second my problems related to displaying preview link on twitter. I can not understand how the link preview can be correctly displayed by the validator, but not displayed by the twitter itself. Can someone explain the problem to me?

Thanks in advance for the answer.


#2

I assume that the “stage-” prefix means that this is a staging server?

It seems to return a lot of HTTP 503 errors (about 90% of the time) which means that validating and rendering the card is problematic. I’ve just tried posting Tweets with and without the “stage-” prefix in the URL and the card renders in some of them but not all of them.

Ultimately, this is down to the availability of the site when the link is published.


#3

Can you please retest posting linkы to twitter? I have a suspicion that when you tested links on stage-journals.lww.com, on our website was deploying system and you can had a problems related to access to our resources.


#4

You should be able to validate and test this yourself. Thanks.


#5

@andypiper As I already wrote, I investigated this problem and I don’t have ideas about it. All validators worked good and displayed preview link as needed to display. Markup contains all twitter meta tags that it should contain. Robots.txt contains rule for twitter:
#twitter.com
User-agent: Twitterbot
Allow: /

Before I tested with this rule:

#twitter.com
User-agent: Twitterbot
Disallow:

And I cannot understand why twitter can’t displayed my preview links.


#6

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.