ERROR: DnsResolutionRequestTimeout

error-codes

#1

I keep receiving “ERROR: Failed to fetch page due to: DnsResolutionRequestTimeout” for my domain, adashofjane.com. Sometimes, Twitter Cards work. Other times, they don’t. I’ve already gone through the process of allowing the Twitter bot in robots.txt


#2

This is a weird issue, seems indeed something is wrong with the Card Validator, as the problem is about DNS resolving. Maybe @andypiper can help?


#3

I’m replying to this instead of creating a new topic, since it’s technical the same error. It was never replied to with a solution, but it seemed to fix after shortly after I posted about my issue (don’t most issues?).

I recently changed my blog URL from one domain to a new one. Before the URL changed, the Twitter cards worked. Now, however, they’re not working—not even the summaries are coming up.

Example: https://twitter.com/gotjane/status/759574131977228288

I’m well aware sites no longer need to be validated, but when I put in anything from a specific URL to the homepage on janepedia.com, the validator either continues circling for over two minutes or gives me the following error:

ERROR: Failed to fetch page due to: DnsResolutionRequestTimeout

Was I supposed to notify Twitter of a domain change? It’s the same site, same files, same everything—except for the domain name.


#4

Could I possibly get an update on this? I’ve tried everything. :confused:


#5

For some reason, our fetcher can’t currently find your domain. I’m afraid I don’t know how to help with this, short of waiting for the new domain to filter into our system. For what it’s worth, the cards markup on your pages looks ok, so hopefully this will resolve itself over time, but I understand it is frustrating right now!


#6

Is there a particular time as to how long it will take for the domain to filter into the system? Because it’s still not showing anything, neither for the above tweet, nor for more recent tweets.