Error code 179 when I attempt to undo retweets from a private account



I’m trying to unretweet entries from a protected account that I don’t follow anymore. I can’t view them in my timeline when I’m logged in to my account, but other followers of the protected account are still able to view these retweets in my profile.

I tried to send a POST statuses/unretweet/:id request using twurl like this:

twurl -X POST /1.1/statuses/destroy/rt-id.json

where “rt-id” is replaced with the data-retweet-id attribute from the tweet I want to delete, but I get the following in response:

{“errors”:[{“code”:179,“message”:“Sorry, you are not authorized to see this status.”}]}

Requests of this type work fine for unprotected accounts though. POST statuses/destroy/:id also triggers the same error response for protected tweets.

Is this a bug? How can I unretweet these posts properly?

btw, I also tried this, but it doesn’t seem to work anymore either.

closed #2

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.


I think you’re using the wrong endpoint in twurl, destroy only works for Tweets that were created by the authed user. is different than